cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vadim Gritsenko" <vadim.gritse...@verizon.net>
Subject RE: Cocoon 2.0.1 and Sun JDK 1.4
Date Mon, 11 Mar 2002 14:45:27 GMT
> From: Allan Kamau [mailto:hugebirdwings@yahoo.com]
> 
> I've been trying to get Cocoon 2.0.1 to run with Sun's
> JDK 1.4 on both RH Linux 7.2 and Win2000 without
> success.
> I get several inconsistant errors on Win2000 running
> TC 4.0.3 I get the error below.

There are number of steps to be done to make JDK1.4 or Tomcat
4.0.2-4.0.3 work with Cocoon. If you are new to Cocoon, JDK1.3.1 and
Tomcat 4.0.1 are highly recommended. Otherwise, be prepared to search
archive where instructions are posted virtually every week on how to
setup Cocoon with JDK1.4 and Tomcat 4.0.2+.

 
> Cocoon 2 - Internal server error
> 
>
------------------------------------------------------------------------
------
> --
> 
> type fatal
> 
> message Language Exception
> 
> description org.apache.cocoon.ProcessingException:
> Language Exception:
> org.apache.cocoon.components.language.LanguageException:
> Error compiling sitemap_xmap: Line 0, column 0: could
> not parse error message: error: Invalid class file
> format in
> d:\j2sdk1.4.0\jre\lib\rt.jar(java/io/OutputStream.class).
> The major.minor version '48.0' is too recent for this
> tool to understand.

PS Error above clearly says that you are using old compiler ('tool')
with new JDK ('rt.jar').

Vadim


---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message