cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Georg Von Sperling" <...@medaptus.com>
Subject RE: Weird problem with JDK 1.4 on win32
Date Thu, 21 Feb 2002 07:20:00 GMT
I ran into that problem as well, but the way I fixed it is to set the Environment Variables
in the System Properties as follows:
 
JAVA_HOME = {path to jdk1.4 (not the -rc, which was all screwy)}
CLASSPATH = .;%JAVA_HOME%/tools.jar;
 
now, your "Path" variable pobably looks like: ;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%JAVA_HOME%\bin;%CATALINA_HOME%\bin;%ANT_HOME%\bin;
 
reverse the attributes, so that it looks like:
 
%JAVA_HOME%\bin;D:\Perl\bin\;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%CATALINA_HOME%\bin;%ANT_HOME%\bin;
 
Windows is screwy that way... the first java.exe it encounters is the one it uses. Windows
ships with java.exe (unless you're using WinXP). If you type "java -version" on the command
line, the correct libs are used, but the wrong java.exe!
 
Hope this helps...
 
Georg von Sperling
MedAptus, Inc., Boston, MA
http://www.medaptus.com
mailto://gvs@medaptus.com
 
-----Original Message----- 
From: Stefano Mazzocchi [mailto:stefano@apache.org] 
Sent: Wed 2/20/2002 5:47 PM 
To: Apache Cocoon; Apache Cocoon Users 
Cc: 
Subject: Weird problem with JDK 1.4 on win32



	I just compiled the fresh CVS and I got a bunch of compilation errors
	such as
	
	class org.apache.cocoon.components.language.markup.xsp.EsqlConnection
	must
	be declared abstract. It does not define void setHoldability(int) from
	interface java.sql.Connection.
	    [javac] public class EsqlConnection implements Connection {
	    [javac]              ^
	
	and so on.
	
	The ant task should be turning that code into comments if JDBC3 is not
	found.
	
	Now, if you install JDK 1.4 on windows, it copies java.exe and javaw.exe
	in your %WINDOWS_SYSTEM% directory (c:\winnt\system32 on my machine).
	
	But i wanted to use JDK 1.3.1 to compile Cocoon so I updated my profile
	to have the JAVA_HOME and PATH set up correctly.
	
	The problem seems to be that Ant calls System.run() and the JDK 1.4
	java.exe is picked up, no matter what PATH definition you have.
	
	So, the JVM that runs ant is JDK 1.3, but the one used to check
	availability of JDBC3 is JDK 1.4, thus the problem.
	
	Deleting java.exe and javaw.exe from /winnt/system32 resolved the
	problem.
	
	--
	Stefano Mazzocchi      One must still have chaos in oneself to be
	                          able to give birth to a dancing star.
	<stefano@apache.org>                             Friedrich Nietzsche
	--------------------------------------------------------------------
	
	---------------------------------------------------------------------
	Please check that your question has not already been answered in the
	FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>
	
	To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
	For additional commands, e-mail: <cocoon-users-help@xml.apache.org>
	
	

Mime
View raw message