cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <Geza.Sz...@nokia.com>
Subject Cocoon and iPlanet again
Date Tue, 12 Feb 2002 12:35:18 GMT
Hello !

  I'm trying to get Cocoon working on an iPlanet
webserver. I have:
	- Cocoon 1.8.2 
	- iPlanet-WebServer-Enterprise/6.0SP1
 	- JDK1.3
      - Windows NT 4
  I followed the install guide, all worked fine.
I can also view the Cocoon.xml, so the servlet
is working somehow, but I still have a problem:
I can't access any other XML file. The mapping
is as advised in the guide: @.*[.]xml. Cocoon
is invoked for surely, that's not the problem, but 
I get an exception from Cocoon. I've looked into
the source code, it seems that the
servlet context is invalid or missing for Cocoon.
I looked for answer in the mailing list and in
FAQ too, but no real help could be found. 
I tried also to rebuild the cocoon.jar, but no
difference. Thanx for any help, Geza
Here't the exception:
----------------------------------------------
java.lang.RuntimeException: Cannot access non-file/war resources
at org.apache.cocoon.Utils.getBasename(Utils.java:253)
at org.apache.cocoon.Utils.getBasepath(Utils.java:276)
at org.apache.cocoon.processor.xslt.XSLTProcessor.getResource(XSLTProcessor.java, Compiled
Code)
at org.apache.cocoon.processor.xslt.XSLTProcessor.process(XSLTProcessor.java:107)
at org.apache.cocoon.Engine.handle(Engine.java, Compiled Code)
at org.apache.cocoon.Cocoon.service(Cocoon.java:167)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
at com.iplanet.server.http.servlet.NSServletRunner.invokeServletService(NSServletRunner.java:891)
at com.iplanet.server.http.servlet.NSServletRunner.Service(NSServletRunner.java:458)
----------------------------------------------

---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message