cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bud Gibson <fpgib...@umich.edu>
Subject Re: XSP not working at all with Cocoon 2.01
Date Mon, 25 Feb 2002 21:15:07 GMT
Thanks, that link is much better than what I found.

Vadim Gritsenko wrote:

>>From: Bud Gibson [mailto:fpgibson@umich.edu]
>>
>>Well, after reading your helpful note, I did manage to locate an
>>
>archive.
>
>>After using a text editor to search it,
>>
>
>:)
>
>Try http://marc.theaimsgroup.com/?l=xml-cocoon-users
>I found this site very useful.
>
>>I found something about tomcat
>>4.02, but it was inconclusive as to what to do.
>>
>>Perhaps there should be a little note under installation concerning
>>tomcat 4.0.2 since it has been out for a while now, and the problem
>>
>seems
>
>>general.  I have seen two posts on the issues I mentioned just today.
>>
>
>Cocoon release file is updated at the time of ...hm... release. So only
>Cocoon 2.0.2 could get any installation note about 4.0.2 issue.
>
>>Given my configuration, it was not obvious that tomcat 4.02 would be
>>
>the
>
>>problem, and the current installation direction suggests Tomcat 4.X is
>>
>the
>
>>easiest installation.
>>
>
>Since some 4.0 beta till 4.0.1 - yes, the easiest.
>
>
>>I think people look for the archives but cannot find them.
>>
>
>Try URL above.
>
>
>>It might help to
>>place URLs directly to them under the signup.  What about using cocoon
>>
>as a
>
>>front-end to the current archive, such as it is.
>>
>
>I think the xml-forrest project will have this functionality.
>
>Vadim
>
>
>>Vadim Gritsenko wrote:
>>
>>>Hi,
>>>
>>>Have you seen *lots* of messages on this list recently saying that it
>>>
>is
>
>>>better to stay with Tomcat 4.0.1 for a moment and that Cocoon does
>>>
>not
>
>>>work with Tomcat 4.0.2? If no, take a look at the archive. Search
>>>
>string
>
>>>'4.0.2' and '4.02' should give lots of results.
>>>
>>>Also search archive for a solution for this problem (however, I can
>>>
>not
>
>>>recall that message with the solution. May be it is not discovered
>>>
>yet).
>
>>>Regarding installation instructions: docs were written before Tomcat
>>>4.0.2 was born, so you should take this into account.
>>>
>>>Regards,
>>>Vadim
>>>
>>>>-----Original Message-----
>>>>From: Bud Gibson [mailto:fpgibson@umich.edu]
>>>>Sent: Monday, February 25, 2002 3:12 PM
>>>>To: cocoon-users@xml.apache.org
>>>>Subject: XSP not working at all with Cocoon 2.01
>>>>
>>>>Hi:
>>>>
>>>>I seem to be having a problem with cocoon, and there is currently no
>>>>FAQ, so here goes.  I list my environment first, and then get to
>>>>specific issues.
>>>>
>>>>I am running the following
>>>>
>>>>Tomcat 4.02
>>>>Sun JDK 1.3.1_02
>>>>no externally set classpath variable
>>>>Redhat 6.2 with kernel 2.2.19 (? unsure about kernel, but that is
>>>>
>>>close)
>>>
>>>>Cocoon 2.01
>>>>1 GB RAM
>>>>2 700 MHz Pentium III
>>>>
>>>>Two issues:
>>>>
>>>>1.  To get cocoon to work at all, I seem to need to have the xerces,
>>>>xml-apis, and batik jars in both the $TOMCAT/lib directory and the
>>>>cocoon WEB-INF/lib directory.  This is a bit contrary to the
>>>>installation instructions.  The problem seems to occur when cocoon
>>>>
>is
>
>>>>trying to compile the sitemap.  It cannot find the classes in those
>>>>
>>>jars
>>>
>>>>unless they are in the $TOMCAT/lib directory.  Later, if I try to
>>>>
>>>access
>>>
>>>>the tutorials or doc, it seems to require that at least the batik
>>>>
>jar
>
>>>be
>>>
>>>>in the cocoon WEB-INF/lib directory.
>>>>
>>>>2.  Now started, cocoon simply seems to stall whenever I try to
>>>>
>access
>
>>>>an XSP page or use SOAP.  The static examples seem to work as do the
>>>>screencraping examples. The only error message I get in the error
>>>>
>log
>
>>>is:
>>>
>>>>>ERROR   (2002-02-25) 14:13.48:366   [sitemap.generator.velocity]
>>>>>(/cocoon/) HttpProcessor[8980][0]/VelocityGenerator:
>>>>>
>ResourceManager
>
>>>:
>>>
>>>>>unable to find resource 'VM_global_library.vm' in any resource
>>>>>
>>>loader.
>>>
>>>>>ERROR   (2002-02-25) 14:13.48:448   [sitemap.generator.velocity]
>>>>>(/cocoon/) HttpProcessor[8980][0]/VelocityGenerator:
>>>>>
>ResourceManager
>
>>>:
>>>
>>>>>unable to find resource 'VM_global_library.vm' in any resource
>>>>>
>>>loader.
>>>
>>>>Any help appreciated,
>>>>Bud
>>>>
>
>
>---------------------------------------------------------------------
>Please check that your question has not already been answered in the
>FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>
>
>To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
>For additional commands, e-mail: <cocoon-users-help@xml.apache.org>
>




---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message