cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From yuryx <yu...@mobicomk.donpac.ru>
Subject Bug In Cocoon2.0.1 ?
Date Sun, 10 Feb 2002 11:25:58 GMT
Hi all!
I have use database within polled connections.
In my JSP page I try:
<?xml version='1.0' encoding="KOI8-R"?>
<%@ page language="java" import="java.text.SimpleDateFormat,java.util.*,
    
java.sql.*,org.apache.avalon.framework.component.ComponentManager,org.apache.avalon.framework.component.ComponentSelector,
    org.apache.avalon.excalibur.datasource.DataSourceComponent"
    pageEncoding="KOI8-R"%>
<page>
    <content>
    <%
       
       
     Connection          conn = null;
     Statement           stmt = null;
     PreparedStatement   pstmt = null;
     ResultSet           rset = null;
     int row_cnt=0;
     StringBuffer sbout= new StringBuffer();
     StringBuffer errors= new StringBuffer();
     ComponentManager manager;
     ComponentSelector selector=(ComponentSelector) 
manager.lookup(Roles.DB_CONNECTION);
     DataSourceComponent datasource=(DataSourceComponent) 
selector.select("my_connection");
     conn= datasource.getConnection();
%>
 </content>
</page>

And I have error .
Yes, I don't found Roles.class in cocoon-2.0.1.jar
And I don't found in cocoon's documentation implementation for this 
features.
This bug or not?
Any ideas?
Thanx
Yury



---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message