cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Laurent CAPRANI" <m237...@er.uqam.ca>
Subject bug? extra-classpath under Windows
Date Sun, 27 Jan 2002 23:27:58 GMT
The extra-classpath feature in web.xml does not seem to work under Windows.

1. Absolute path
Cocoon uses a non portable method when guessing whether the path is absolute
or not.

If I add the following to web.xml:
------
<init-param>
 <param-name>extra-classpath</param-name>
 <param-value>C:\extra-classes</param-value>
</init-param>
------
This path is not recognized as absolute. The resulting classpath is
(according to cocoon.log) "%tomcat%\webapps\cocoon\WEB-INF\C:\extra-classes"

Putting an extra \ in front of the path makes turns it to
"\C:\extra-classes" (which is not a valid path).

2. Relative path
Relative path do not seem to work either.
When I put this in web.xml:
------
<init-param>
 <param-name>extra-classpath</param-name>
 <param-value>extra-classes</param-value>
</init-param>
------
A directory is apparently added to the classpath:
(cocoon.log)
DEBUG   (2002-01-27) 17:55.48:739   [cocoon  ] (Unknown-URI)
Unknown-thread/Cocoon: Classpath =
...;%tomcat%\webapps\cocoon\WEB-INF\extra-classes

But my component.class is found by Cocoon under
%tomcat%\webapps\cocoon\WEB-INF\classes, but not under ...\extra-classes.

By browsing the archives, it seems some people allready experienced the
problem:
http://www.mail-archive.com/cocoon-users@xml.apache.org/msg05691.html



---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message