cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Berin Loritsch <blorit...@apache.org>
Subject Re: JDK 1.4 pre
Date Thu, 24 Jan 2002 14:33:33 GMT
Alex Kachanov wrote:

> hello!
> 
> It looks like smth. is wrong.
> Cocoon cannot run with the latest release of JDK 1.4 Pre from Sun.
> I get such messages like:
> 
> Invalid class file format in F:¥jdk¥jre¥lib¥rt.jar(java/io/OutputStream.class). 
> The major.minor version '48.0' is too recent for this tool to understand.


If you compile Cocoon with JDK 1.4, you have to do the following:

1) run the servlet container with JDK 1.4
2) use JDK 1.4's tools.jar file

If you want to use the same cocoon.jar file in any installation, then set the
version="1.2" attribute on the <javac> tag that compiles Cocoon.  That way
the classes are binary compatible with the previous versions of JDK.

Bear in mind this LAW:

Your tools.jar MUST be from the SAME JDK as you  are RUNNING.





-- 

"They that give up essential liberty to obtain a little temporary safety
 deserve neither liberty nor safety."
                - Benjamin Franklin


---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message