cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bernhard Huber <berni_hu...@a1.net>
Subject Re: weblogic sitemap_xmap.java problem (again!)
Date Thu, 17 Jan 2002 20:56:42 GMT

Helly, Aidan wrote:

>Hi,
>
> I am trying to get cocoon working with weblogic6.1, and have run up against
>what seems from the mailing list archive to be a common problem, namely:
>the sitemap_xmap.java file generated is empty, resulting in a ClassNotFound
>exception the first time the CocoonServlet is accessed.
>
> Has anyone out there, found a solution/work-around to this problem?
>
yes,
in the mailing-lists, search for wls, or wls6.1
or change your
cocoon.xconf:

<xslt-processor class="org.apache.cocoon.components.xslt.XSLTProcessorImpl"
  logger="root.xslt">
  <parameter name="use-store" value="true"/>
  <parameter name="transformer-factory"
    value="org.apache.xalan.processor.TransformerFactoryImpl"/>
</xslt-processor>

this overrides the XSLT shipped with wls6.1.
Then sitemaps should get generated.

You may try to override the XML parser, too.
But the above should help in the first run.

bye
bernhard


---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message