cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sharat Koya <sxk...@Cs.Nott.AC.UK>
Subject RE: Logicsheet woes
Date Thu, 03 Jan 2002 11:46:04 GMT
Ok I think the error was in my XSL coding in the logicsheet. All works
well now
thanks
-----Original Message-----
From: Jeremy Aston [mailto:jeremyaston@yahoo.co.uk] 
Sent: Thursday, 03 January 2002 10:17
To: cocoon-users@xml.apache.org; sxk99c@Cs.Nott.AC.UK
Subject: RE: Logicsheet woes
 
Great - just wanted to clear out the obvious ;-) 
A few more pointers.... 
Firstly you may want to enclose your uri param value in double quotes in
the xconf entry.  It shouldn't make a difference but I always like to
make sure. 
The other thing is the href value.  If you check the instructions in the
ctwig idiots guide docs (part of the C2 docs) then you will note the use
of the "resource" protocol.  This is telling C2 to look (amongst other
places) the classes folder under WEB-INF.  I'm not sure off the top of
my head what using href without any protocol identifier, as you are
doing, will do and where C2 will look for the logicsheet.  It could be
that C2 cannot find the logicsheet.  Try using the resource or file
protocols. 
The final question is if there are there any log messages that relate to
this?  If so they are probably the best guide as to what is wrong. 
The examples in ctwig work and are there to be used as a skeleton if you
want something proven to test. 
Regards 
Jeremy 
  Sharat Koya <sxk99c@Cs.Nott.AC.UK> wrote: 
Yeah quite sure :-)
 
-----Original Message-----
From: Jeremy Aston [mailto:jeremyaston@yahoo.co.uk] 
Sent: Thursday, 03 January 2002 09:14
To: cocoon-users@xml.apache.org; sxk99c@Cs.Nott.AC.UK
Subject: RE: Logicsheet woes
 
Hi, 
Might sound patronising, but are you including the player-info namespace
attribute in the actual xsp file that calls the logicsheet? 
Regards 
Jeremy 
  sxk99c@Cs.Nott.AC.UK wrote: 
Does anyone have a simple logicsheet skeleton code and instructions of
how to test it please? I keep can't seem to get round the problem below.
I think I have narrowed it down to a xsl problem?

Thanks for any help
Sharat Koya

-----Original Message-----
From: sxk99c@Cs.Nott.AC.UK [mailto:sxk99c@Cs.Nott.AC.UK] 
Sent: Wednesday, 02 January 2002 17:03
To: cocoon-users@xml.apache.org
Subject: Logicsheet woes

Hi again, I have started to try and implement a simple logicsheet as
shown :

I followd the procedure of adding a logic sheet to the cocoon.xconf:

Cocoon.xconf 




value=http://dahl.cs.nott.ac.uk/eclipse/player-info/1.0
/>

value="docs/logicsheets/player-info.xsl"/>
! 


Then created the logicsheet bellow:

player-info.xsl (logicsheet)


xmlns:xsp="http://apache.org/xsp" 
xmlns:xsl="http://www.w3.org/1999/XSL/Transform" 
xmlns:player-
info=http://dahl.cs.nott.ac.uk/eclipse/player-info/1.0
>








hello










then I call my new tag in a different xsp file with
the new namespace and nothing ha! ppens. The tag is simply ignored.
There
are no visible errors in the logs. Can anyone help??


---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. 

To unsubscribe, e-mail: 
For additional commands, e-mail: 



---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. 

To unsubscribe, e-mail: 
For additional commands, e-mail: 
 

  _____  

Do You Yahoo!?
Get personalised at My
<http://uk.rd.yahoo.com/mail_uk/my?http://uk.my.yahoo.com>  Yahoo!.
 
  _____  

Do You Yahoo!?
Get personalised at My
<http://uk.rd.yahoo.com/mail_uk/my?http://uk.my.yahoo.com>  Yahoo!.

Mime
View raw message