cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Rosenstrauch <dar...@dti.net>
Subject Re: [c1] java.lang.NoClassDefFoundError with custom class?
Date Fri, 14 Dec 2001 17:39:11 GMT
Loose classes go in WEB-INF/classes.  Jar files go in WEB-INF/lib.

If your code is in a jar file then you put it in the wrong place.


DR


At 12:29 PM 12/14/01 -0500, you wrote:
>I'm running Cocoon 1.8.2 and I've just upgraded from Tomcat3.x to Tomcat4.0.1.  According
to Tomcat's documentation, anything in WEB-INF/classes is available (so I dont have to put
it in my classpath). I've got my own com.blah.globals package in WEB-INF/classes/com/blah/globals.
 When I try and import this in my cocoon logicsheet I get a NoClassDefFoundError:
>  
>java.lang.NoClassDefFoundError: com/rrp/globals/Globals
>at _home._reedy._docs._production._pcteachit_com._temp.<init>(_temp.java:33)
>at java.lang.Class.newInstance0(Native Method)
>at java.lang.Class.newInstance(Class.java:237)
>If anyone has any ideas on this I would really appreciate it.  I tried adding it to my
classpath and restarting everything and I still get the same error.
>  
>Thanks!
>  
>- Brent


---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message