cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From david.grea...@idl-bt.com
Subject SOLVED?: Connection refused after installing Cocoon + X11 comment s
Date Mon, 10 Dec 2001 09:42:08 GMT
Hi

I ma have solved this problem - certainly I had the same issue:
 # tomcat4 run
started tomcat fine; I waited a while (minutes!) the made a req to
http://tc/
Worked fine, tomcat4 demos fine
Then a connection to /cocoon/
Instant death!
All the tomcat4 processes died - no errors no (useful) logs - just X11
connection closed...

This was a virgin RH7.2 install on an SMP i386 machine.
I had downloaded suns jdk1.3.1_01 to /usr/java/jdk1.3.1_01
installed the tomcat4 noarch rpm to /var/tomcat4 (nb someone fix the
/etc/passwd entry for the tc4 user - the homedir is /var/tomcat not
/var/tomcat4 - also need a chown -R tomcat4.tomcat4 /var/tomcat4)

The cocoon binary failed (haven't retried) so I did a build.sh from the
source.

Then I had the problem described above: (search fodder :)
cocoon2 died after one request
no tomcat4 instances running
no error messages

I had X working (xhost+ over SSH etc) - but it took a while to realise that
this fails after a su to tomcat4 :(

After much log reading we tried the 'headless' install using jpa - nb there
were few clues that this was it and the fact that X was working kinda
red-herring'ed us)
This (http://xml.apache.org/cocoon/installing/index.html) suggested jpa from
www.eteks.com 
I installed the .jars to /usr/java/jdk1.3.1_01/fre/lib/ext as Sun suggest -
this failed to work with class loading problems.
We then explicitly unjarred the pja.jar to a new classes directory that we
had to create in /usr/java/jdk1.3.1_01/jre 
(ie mkdir /usr/java/jdk1.3.1_01/jre/classes)
Cocoon then worked :)


I hope this helps...

Looking forward to some serious work now :)

David Greaves




Included the old thread for searching:

Hi Marcus,

thank you for your answer.

On Monday 03 December 2001 06:22 pm, you wrote:
> Hi Tilman,
>
> On Mon, Dec 03, 2001 at 06:22:24PM +0100, Tilman Rassy 
wrote:
> > Catalina.stop: java.net.ConnectException: Connection
> > refused java.net.ConnectException: Connection refused
> > ...<snip>...
>
>       hmm. looks like your Tomcat crashed just after startup
> for some reason.

Yes, I think you are right. I tried again and checked 
whether Tomcat was still running after the attempt to 
access Cocoon. It was not.

>
> > The Cocoon version is 2.0, my servlet container is
> > Tomcat 4.0.1, my java is sun's SDK 1.3.1, and I work on
> > a Linux machine (kernel 2.4.4-4GB).
> >
> > Obviously, the cocoon.war file was extracted (I found a
> > cocoon subdirectory in webapps, and a lot of
> > Cocoon-related messages in the Tomcat log files).
> > Without Cocoon, Tomcat works well.
>
>       I think those messages in the tomcat logs are probably
> useful for diagnosing what's going on. Without them it's
> a bit difficult. Can you send them in ?

See attachments. (The log files comprise two subsequent 
Tomcat sessions)

Thanks again,

---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message