cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Derek Hohls" <dho...@csir.co.za>
Subject Re: [C1] Installation woes [rant AND request] - PLEASE help!
Date Fri, 09 Nov 2001 07:44:56 GMT
Lajos
Thanks - I have actually done all this - tho' I only have just put mysql_comp.jar in $TOMCAT_HOME/lib
That's what so frustrating... it all *looks* the same on each machine [settings-wise] but
behaves differently!  If you could send a copy of whatever files you think are relevant, I
would appreciate that.
Derek


>>> lmocz@galatea.com 09/11/2001 09:38:49 >>>
Sure we're still running 1.8.2; works for my site and probably will 
until I ever find the time to upgrade to 2.01.

Basically, here is how I got it all to work (1.8.2 w/ Tomcat 3.2.2 & 
MySQL on both Linux & Win 98):

1) added mysql_comp.jar to Tomcat's classpath (I just edited tomcat.sh 
/tomcat.bat, but I suppose you could just throw it in $TOMCAT_HOME/lib


2) edited cocoon.properties and added a line to for the mysql driver:

processor.xsp.pool.database.adaptor.DBMM=org.gjt.mm.mysql.Driver

(add this after the other adaptors: note that DBMySQL is incorrect!).


3) edited cocoon.properties and added the connection info for the pool:

processor.xsp.pool.database.default.driver=org.gjt.mm.mysql.Driver
processor.xsp.pool.database.default.url=jdbc:mysql://localhost/mydatabase
processor.xsp.pool.database.default.username=myuser
processor.xsp.pool.database.default.password=mypass
processor.xsp.pool.database.default.maxConnections=3
processor.xsp.pool.database.default.expiryTime=3600000


4) restarted tomcat


Let me know if this still doesn't work & I can send you copies of the 
actual files.

Lajos
galatea.com



Derek Hohls wrote:

> You can skip the rant and read the request at the end...
> 
> <rant>
> 
> "I come to bury Caesar, not to praise him" Julius Caesar, Act III, Scene ii
> 
> So, at one time in my life, I was a Windows programmer [well, still am, really].  And
life was occasionally frustrating, but mostly colorful and satisfying.  And then came the
Web.  Wow!  New ideas, new paradigms, and new languages to learn... and boy, did they come
thick and fast in a stream of acronyms... HMTL, CSS, JS; followed by XML, JSP, XSLT.  I did
my best to absorb them all and see how and where they could be used to help those around [non
techies, mostly] me to make use (and sense!) of this 'information revolution'.  
> 
> Looming over it all, of course, is the ongoing conflict between Sun [Java] and Microsoft
[VB/ASP et al].  Open source vs vendor.  Being in a poorish country, with limited resources,
OS made financial sense; and the paradigm and philosophy was one that appealed to my nature.
 But what to use?  I did not have the luxury of time to contribute (or, in most cases, even
the expertise) to a new area, and needed something that was useful and intuitive to use. 
Then I found Cocoon - at last, something that tied together everything I had been learning
in a meaningful way.   I installed it - it worked [pretty much - BUT see below] and I started
designing, developing and coding.  I scorned those others who were suggesting - dare I say
it aloud - M$ tools such as VBScript, ASP or even Oracle Web Developers XYZ; "don't be fooled,
I said, big companies do not have your interests at heart - OS is the way, the truth... well,
anyway, it's good and What We Should Be Doing".  That was then.  
Now (for the last 4 weeks) I have been desperately trying to get a UNIX box working to replicate
what I have on my development machine; while colleagues [techie and non techie] alike are
watching with increasing scepticism as they move on with Oracle, ASP and Access [choke] et
al.   No one is actually smirking yet.... at least not to my face.  I have posted before -
but the traffic seems thick with [c2] and [docbook] queries... maybe I am the last person
on the planet still trying to use 1.8?
> 
> Is it too late - maybe M$ will take me back - "look, son, here is an ASP primer and an
Intro to VB - its not hard... you don't really need that U**X... let me dim the lights for
you...".
> 
> </rant>
> 
> <request>
> 
> Seriously, I really do need help trying to finalize my Cocoon installations.   I have
3 machines, and each of which has a slightly different problem.  All are running Apache/Tomcat/Cocoon
1.8.2/mySQL.
> 
> Machine 1: Win2000 (development)
> - dbPool does NOT work BUT embedding Database properties in <esql> tags does 
> 
> Machine 2: UNIX (test)
> - dpPool works BUT embedding Database properties in <esql> tags does NOT
> 
> Machine 3: UNIX (Deployment)
> - neither dbPool or embedded properties works!
> 
> I am sure the problems lie with some configuration or file location SOMEWHERE, but have
run out things to try ... apart from pushing buttons at random.  If I cannot solve this very
soon, it will be back to M$ tools and that would not, I think, be good for my soul.
> 
> ARE THE DEVELOPERS STILL OUT THERE (do they care?)
> 
> </request>
> 
> Many thanks for listening
> Derek
> 
> dhohls@csir.co.za 
> 
> 
> 
> ---------------------------------------------------------------------
> Please check that your question has not already been answered in the
> FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>
> 
> To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
> For additional commands, e-mail: <cocoon-users-help@xml.apache.org>
> 
> 



---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message