cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "SANSONE, AARON M [Non-Pharmacia/1000]" <aaron.m.sans...@monsanto.com>
Subject C2 Problem Rendering XHTML Files without Transformation...
Date Fri, 05 Oct 2001 17:57:14 GMT
I am attempting to send XHTML files (as is) through C2.  To do this I
created a match pattern in sitemap as follows:


-------excerpt from sitemap.xmap--------

  <map:match pattern="fp/*.xhtml"> 
    <map:generate type="file" src="fp/xhtml/{1}.xhtml"/> 
    <map:serialize/> 
  </map:match>

----------------------------------------

This should match any pattern of an xhtml file extension, generate it from a
file name and serialize the data without changing it.  However, if I have a
<!DOCTYPE> tag at the top of my file, the generated output always starts
with a greater than symbol.  For example the following file is processed:

-----------index.xhtml------------------

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<html>
	<head>
		<title>Untitled Document</title>
		<meta http-equiv="Content-Type" content="text/html;
charset=iso-8859-1"/>
	</head>

	<body bgcolor="#FFFFFF">
		<h2><font color="#3333FF" face="Verdana, Arial, Helvetica,
sans-serif">Web Test</font></h2>
	</body>
</html>

-----------------------------------------

The output generated is (C2 puts a great deal of comments at the top of the
document so I will only give the offending piece):

----------output from C2----------------

<!-- Scope is simpler than headers attribute for common tables -->
<!-- th is for headers, td for data and for cells acting as both -->>

<html xmlns="http://www.w3.org/1999/xhtml">
	<head>
		<title>Untitled Document</title>
		<meta http-equiv="Content-Type" content="text/html;
charset=iso-8859-1"/>
	</head>

	<body bgcolor="#FFFFFF">
		<h2>
<font color="#3333FF" face="Verdana, Arial, Helvetica, sans-serif">Web
Test</font>
</h2>
	</body>
</html>

-----------------------------------------

Notice that the <!DOCTYPE> code is missing and a > is all that is left of
it.

Does anyone know how to resolve this?  I want the <!DOCTYPE> tag to be
returned.

Thanks in advance,

Aaron

---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message