cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeremy Aston <jeremyas...@yahoo.co.uk>
Subject Re: Logicsheets
Date Tue, 09 Oct 2001 11:41:01 GMT

 Hi Henrik,
>From a cursory view I can't see anything wrong but the problem may be to do with the way
your source XML (XSP) and rendering XSL work.  Can you send these please along with the sitemap
mapping you are using just in case...
Regards
Jeremy
  Henrik Hofmann <Henrik.Hofmann@creon-it.com> wrote: 

Hi,

 

I’m having trouble to apply my own Logicsheet. I’ve already use Logicsheets in the last
beat Version of cocoon 2 and it worked. I’m trying to do this again with the rc1 version
and nothing happens. First I’ll show my entries to xconf and the logicsheet.

 

     <builtin-logicsheet>

          <parameter name="prefix" value="cre"/>

          <parameter name="uri" value="http://www.creon-it.com"/>

          <parameter name="href" value="file:///f:/webserver/tomcat/webapps/cocoon/creon/CreonDataLogik.xml"/>

     </builtin-logicsheet>

 

 

The File CreonDataLogik.xml looks like this:

 

<?xml version="1.0"?>

<xsl:stylesheet version="1.0"

  xmlns:xsl="http://www.w3.org/1999/XSL/Transform"

  xmlns:xsp="http://apache.org/xsp"

  xmlns:cre="http://www.creon-it.com"

>

<!--

-->

 

<xsl:template match="cre:ref">

<h1>test</h1>

</xsl:template>

 

<xsl:template match="@*|node()" priority="-1">

  <xsl:copy>

    <xsl:apply-templates select="@*|node()"/>

  </xsl:copy>

</xsl:template>

 

</xsl:stylesheet>

 

 

 

(this should do some more sophisticated stuff later J)

 

In my xsp file or xsl stylesheet I’m adding my namespace, but when I try to use <cre:ref/>
nothing happens. There’s no error message in the log files.

 

Is ther anything I might have forgot?



bye



---------------------------------
Do You Yahoo!?
Get your free Yahoo! address at Yahoo! Mail: UK or IE.

Mime
View raw message