cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Torsten Curdt" <tcu...@dff.st>
Subject RE: Getting Started with XSP on Coccon2
Date Tue, 18 Sep 2001 11:57:56 GMT
> Hello Coccon users!
> 
> I'm going through the XSP documentation and try to do the following
> example (which, surprisingly, is not part of the supplied examples.  I
> would recommend that releases should include a working setup of the
> documentations example so that one can see how they integrate with
> other, more complicated concepts such as sitemaps).

Just have a look there are plenty of them now...

> 
> <!-- greeting2.xml -->
> <?xml version="1.0"?>
> 
> <?cocoon-process type="xsp"?>
> <?cocoon-process type="xslt"?>

You don't use PIs in C2. You use the sitemap for this.

> <?xml-stylesheet type="text/xsl" href="greeting.xsl"?>

Here as well.

>   <xsp:page xmlns:xsp="http://www.apache.org/1999/XSP/Core">
>     <xsp:logic>
>       String msg = "Hello World!";
>     </xsp:logic>
> 
>     <greeting>
>       <xsp:expr>msg</xsp:expr>
>     </greeting>
> 
>   </xsp:page>
> 
> But the output are just the html tags as specified in greeting.xsl.
> No hello World whatsoever :(
> 
> I am using a sub sitemap for these examples.  I suspect it is the
> culprit.

Looks fine at the first glance...
--
Torsten

---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message