cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Enric Staromiejski" <en...@nxtsis.com>
Subject a very strange behaviour related to getting pages thru port 80 (amazingly solved)
Date Wed, 29 Aug 2001 16:33:56 GMT
Solution:

BY MISTAKE (mistakes are very productive sometimes) we had the following
lines in the public box's tomcat/conf/my-mod_jk.conf:


JkMount /cocoon/servlet/* ajp12
JkMount /cocoon/*.jsp ajp12
JkMount /cocoon/*xml ajp12

When we added the last file to the my-mod_jk.conf we intended to write
"JkMount /cocoon/*.xml ajp12" but instead we wrote "JkMount /cocoon/*.xml
ajp12". So we've modified the box's 2 conf file and it works!

My questions now are the following:

1. Could any one explain why is this working?
2. Was it explained anywhere?

Hope it'll be useful

Enric (not Eric)




-----Mensaje original-----
De: Enric Staromiejski [mailto:enric@nxtsis.com]
Enviado el: miƩrcoles, 29 de agosto de 2001 15:36
Para: cocoon-users@xml.apache.org
Asunto: RE: a very strange behaviour related to getting pages thru port
80


We forgot explaining that both boxes work ok when cocoon is invoked thru
port 8080.

Thanks


-----Mensaje original-----
De: Enric Staromiejski [mailto:enric@nxtsis.com]
Enviado el: miƩrcoles, 29 de agosto de 2001 15:27
Para: cocoon-users@xml.apache.org
Asunto: a very strange behaviour related to getting pages thru port 80


We've got Cocoon installed on 2 Redhat 7.0 boxes:

box 1 (production box, public on Internet):

	OS: RedHat 7.0
	jdk1.3.1
	Tomcat 3.2.1
	Cocoon 2.b02

box 2 (experimental box, inside a Lan)

	OS: RedHat 7.0
	jdk1.3.1
	Tomcat 3.2.3
	Cocoon 2.b02


We always try to clone the experimental machine and the production machine
in order not having strange suprises.
Between these 2 boxes, apparently the only difference is the Tomcat version.
When trying the default Cocoon examples given by the default installation of
Cocoon on the box 1 (the one public on Internet) everything goes fines. For
example: http://www.nxtsis.com/cocoon/xsp/simple ,
http://www.nxtsis.com/cocoon/i18n/simple.xml,
http://www.nxtsis.com/cocoon/session/sessionpage.xsp , etc. are working ok.
But when trying the internal box 2 we only can acceed
http://andrea.esespasa.com/cocoon/i18n/simple.xml and
http://andrea.esespasa.com/cocoon/i18n/simple.xsp returns the xml code. All
other examples return "Page not found".

Tomcat and Cocoon configuration files are identical in both machines.


Any idea...?






---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message