cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jan Uyttenhove" ...@pandora.be>
Subject RE: [C2b2] Unicode output
Date Wed, 01 Aug 2001 20:06:03 GMT
We had the same problem with french characters.
I had to set the file.encoding system property (on Solaris), because the
generated java code (from xsp) and our logging both contained '?' instead of
the french characters. So the problem actually occurred when writing on
disk...

Don't know if this helps you out.
What's your OS? Do you use xsp's?
Do you specify an encoding when serializing?

Jan


Jan Uyttenhove
Software Engineer




-----Original Message-----
From: Wes Morgan [mailto:wesm@slacknet.org]
Sent: maandag 30 juli 2001 22:09
To: cocoon-users@xml.apache.org
Subject: [C2b2] Unicode output


I am working with some XML documents that have Greek and Hebrew Unicode
characters in them. I am using Unicode fonts on the client side, so I need
these characters to come through unmodified, but Cocoon changes them to '?'
if it doesn't recognize them and to a character entity (e.g. ε) when
it does. This is bad, I need Cocoon to leave these characters alone. Any
suggestions? Thanks.

Wes Morgan
www.ccel.org


---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>




---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message