cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bernie Lee <ber...@infopro.com.my>
Subject Another successful story about Cocoon C2b2 (with Tomcat4 on W2KPr o)
Date Wed, 29 Aug 2001 03:18:00 GMT
hi all.

after a few days of messing around trying to get C2 working with tomcat
3.2.2 and 3.2.3 to no avail (i kept getting SAX and sitemap errors on all 3
machines i tried - 2 at work and 1 at home), i've finally managed to install
C2 successfully. i think the problem is with T3.

so... i decided to try T4. i downloaded the T4 executable(!), edited
web.xml, and built cocoon.war, and the C2 welcome page loaded and the
samples worked! so for any of u who are still having trouble setting up T3,
i suggest trying T4 instead for a hassle-free install. i've done it twice
already and it has worked both times.

my config is below:

- w2kpro
- tomcat 4b7
- c2 b2
- soap 2.2

(this is just my 2c for the w2k platform)




-----Original Message-----
From: Walter G. da Cruz [mailto:wdacruz@pacbell.net]
Sent: Saturday, August 25, 2001 1:42 PM
To: cocoon-users
Subject: A successful story about Cocoon C2b2



	After _several_ tries, building Cocoon from scratch, and reading
most of the 
e-mails from the newsgroup/Java Guru/Web site documentation, I finally
managed to 
make Cocoon work on my Personal Web site!
	Thank you very much Steffano and the Cocoon team for this wonderful
servlet!  Here 
is my configuration:

	RedHat Linux 7.1 Kernel 2.4.1 i386 architecture.
	SUN JDK 1.3.1 b24
	Jakarta-Tomcat 3.2.3
	SOAP 2.2 (just in case somebody need it).

	Here are some notes I came across during the installation:
	1. run dos2unix bin/ant and dos2unix bin/antRun
	2. rerun build.sh.
	3. rename jaxp.jar for jaxp.jar.old (according to the documentation)
	4. rename parser.jar for zparser.jar
	5. Copy the xerces-1.4.1 into $TOMCAT_HOME/lib/

	Then, I started getting:

type internal-server-error

message The sitemap handler's sitemap is not available. Please check
/opt/java/jakarta-tomcat-3.2.2/webapps/cocoon/WEB-INF/logs/cocoon.log for
the exact error.

	This problem went away after I installed jakarta-tomcat-3.2.3 (and
rebuild ed 
cocoon from scratch).
	
	6. The next error message I received was: (from
$TOMCAT_HOME/logs/servlet.log or 
from the Http://localhost:8080/cocoon/):

org.xml.sax.SAXException: Could not get valid parserNamespace not supported
by 
SAXParser

path="/cocoon" :ERROR   99871   [cocoon  ] (main): Cannot produce a valid
parser
javax.xml.parsers.ParserConfigurationException: Namespace not supported by
SAXParser


	7. Now, the problem is the parser.  I remember,back of the time I
was trying to 
install Cocoon 1.8.x, that xerces had to be the first .jar that is loaded
from the 
$TOMCAT_HOME/lib directory.  Therefore, I renamed xerces-1.4.1.jar as 
aaxerces-1.4.1.jar (a dirty solution, but it works).

	8. Then, I received another error message: The sitemap can not open
the display 
(0,0) (from 
/opt/java/jakarta-tomcat-3.2.2/webapps/cocoon/WEB-INF/logs/cocoon.log).  I
was 
connecting to my machine remotely using ssh.  The error message suggests
that 
sitemap was trying to open a window in the local display.  So I wait until I
went 
home and run the program locally.

	9. Went I tried at home, to my enjoy, Cocoon started.  After I was
able to fired up 
cocoon from my local machine, I was able to connect from other machines.  I
guess, 
the first time you try to run Cocoon, you have to try in the machine itself.
If 
you want to take a look at it:

http://63.195.86.146:8080/cocoon/welcome

	Again, thank you Steffano and the Cocoon team for this,

			Walter


-- 

  "If we were logical, the future would be bleak indeed. But | (408)294-4750
  we are more than logical. We are human beings, and we have |
wdacruz@wdacruz.com
faith, and we have hope, and we can work" -Jacques Cousteau |
http://wdacruz.com
------------------------------------------------------------|---------------
------



---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>

---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message