cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Haul <h...@dvs1.informatik.tu-darmstadt.de>
Subject Re: using XSP : element ???
Date Fri, 17 Aug 2001 07:57:12 GMT
On 17.Aug.2001 -- 10:48 AM, Kazi the P i R @ t {- wrote:
> Actually i am not using any comments in the real file... i only put it in
> when i posting the message for the readers' benefit.
> 
> So the block actually looks like this:
> 
>    <product>
>                <xsp:attribute name="id">
>                  <xsp:expr>temp_bullet</xsp:expr>
>             </xsp:attribute>
>            <name>
>                <xsp:expr>temp_gun</xsp:expr>
>             </name>
>     </product>

> > >org.xml.sax.SAXParseException: The content of elements must consist of
> > >well-formed character
> > >                 data or markup.

Wild guess: id attributes may not contain spaces (they follow the same
rules like e.g. element names). Thus perhaps the following might work:

   <xsp:attribute name="id"><xsp:expr>temp_bullet</xsp:expr></xsp:attribute>

	Chris.

-- 
C h r i s t i a n       H a u l
haul@informatik.tu-darmstadt.de
    fingerprint: 99B0 1D9D 7919 644A 4837  7D73 FEF9 6856 335A 9E08

---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message