cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@indexgeo.com.au>
Subject Re: success install 2.0b2 Linux RH7.1, Blackdown JDK 1.3.1, Tomcat 3.2.2
Date Sat, 18 Aug 2001 02:11:55 GMT
That may well have been a misguided statement.
Recently, similar build error messages reveal that
these java.lang.NoSuchMethodError can be because of
a clash between versions of classes and the class
loading order.

We had an additional package.jar in our lib/ directory
which contained some classes that would normally be
loaded by Cocoon. Because its name started with "c" it
was loaded early, So our older version of the classes
took precedence. Hence our recent build errors. Removing
the old classes from our jar and re-packing fixed it.

Perhaps those old errors were from a similar cause.
Anyway, changing the Xerces jar name did fix our previous
issue. I notice that the current build.sh in 2.1-dev cvs
does not even mention the specific CLASSPATH hack to add
xerces for build time.
David Crossley

David Morris said:
> I am not so sure that this is a problem with the build script.
> I get the
> same  error when I use IBM's 1.3 JDK.  I can immediately switch
> to Sun's JDK and  the error goes away.
> David Morris
>
> >>> crossley@indexgeo.com.au 07/29/01 06:55PM >>>
> java.lang.NoSuchMethodError: org.xml.sax.Attributes: blah, blah
> [localhost]$ vi ./build.sh
> ... build.sh was referencing the wrong version of xerces
> ... changed xerces_1_4_0.jar to xerces_1_4_1.jar
> ... now it works
> regards, David Crossley

---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message