cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Colin Paul Adams <co...@colina.demon.co.uk>
Subject Re: First-timer - can't get cocoon 2 to work
Date Sun, 01 Jul 2001 09:14:57 GMT
>>>>> "Liam" == Liam MacQuarrie Morley <lmorley@WPI.EDU> writes:

    Liam> Colin, my first guess would be that you are using the same
    Liam> XML parser that came with Tomcat. This isn't compatible with

No - I read the FAQ, and the install instructions (but the latter seem
inadequate - it appears to me that it is necessary to tailor the
sitemap.xmap first).

Anyway, I tried removing crimson.jar from jre/lib/ext - that appears
to make a difference (but it is not acceptable to me). Now cocoon just
hangs in the init method (at least, involikng that method is the last
thing in the tomcat log).

I thought at first that it might just be taking a long time to compile
- so I tried following the advice in the FAQ for pre-compiling cocoon
- however, I came up against two problems:

1) I don't know whereabouts in the sitemap to place the <parameter name="auto-reload">
   tag for supressing reloads.

2) When I try specifying -Dcompile.xsp=yes, the build process hangs
   after a while, following a series of DEBUG messages, the last of
   which is:

DEBUG   99397   [cocoon  ] (main): ComponentFactory creating new instance of org.apache.avalon.excalibur.datasource.JdbcDataSource.

I guess I have to tailor the sitemap to specify a valid JDBC data
source?? How?

Anyway, I reckon if the build process can't compile xsp, then neither
can the cocoon runtime init method, so maybe these are related problems.
-- 
Colin Paul Adams
Preston Lancashire

---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message