cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From giacomo <giac...@apache.org>
Subject Re: Dont use servlet_2_2.jar with C2+Struts
Date Wed, 02 May 2001 19:13:26 GMT


On Wed, 2 May 2001, Sylvain Wallez wrote:

>
>
> giacomo a écrit :
> >
> > On Mon, 30 Apr 2001, Jon Brisbin wrote:
> >
> > > I finally removed the servlet_2_2.jar file from the tomcat/lib directory,
> > > replaced the servlet.jar that comes with tomcat 3.2.1 and Struts works great
> > > with C2 with the JspGenerator.  Apparently, the new method that handles
> > > getting the attributes of the taglib directive takes a different number of
> > > arguments??
> >
> > I don't fully understand the reason. Is C2 using an old/incompatible
> > servlet jar?
> >
> > Giacomo
> >
> Couldn't it be a ClassLoader issue ? Where does Jasper search for JSP
> taglibs ?

As far as I know we don't included the servlet.jar in the war file, thus
it could be a Classloader problem, but I'm not sure. Concerning JSP I
have no idea where jasper searches for taglibs (I'm not using JSP at
all). BTW: are taglibs portable across servlet engines?

Giacomo


---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message