cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From paint...@mc.duke.edu
Subject Re: request????????????
Date Thu, 03 May 2001 20:56:20 GMT

Where in your XSP document is the <xsp:logic> block in which you are trying
to use request?  You can't access request, for instance, outside the
<xsp:page> element - it doesn't exist yet.

I would also suggest that you look at the generated Java code - you can
quickly tell from that where request is being declared (or if) and where
your reference to it is.

-Christopher





Hi -

On win2000 I have an installation of
Apache 1.3.12, Jakarta-tomcat 1.1 and
Cocoon 1.8.1

Most of it works all right, but I have
a problem using "request" with
xsp in Cocoon.

I have for instance ...

<xsp:logic>
String[] roleValues = request.getParameterValues("userRole");
....
</xsp:logic>

... in a xml/xsp page, and get the error:
"Undefined variable or class name: request"

In the xsp-doc page I can read:
"request. A Cocoon-supplied wrapper to
the standard HttpServletRequest object.
This wrapper provides all the functionality
defined for its JSDK interface counterpart."

... and in the same doc there is lots of examples using
"request" as shown.

If I use the "Request"-taglib things work fine.
If I include the namespace
xmlns:request="http://www.apache.org/1999/XSP/Request"
I can use "<request:get-parameter name="name"/>" and get
the name-value from the html-form!

I've tried what I could think of - and some more.
servlet2.jar & servlet2_2.jar!
Changing the order of jar-files in my classpath, but
nothing seems to make any difference.
I've tried to include the servlet-classes in the
xml-xsp-page (it shouldn't be necessary) - no dice.
There is nothing in the faq about the problem!

Cocoon can't find "request"! Why? Any ideas?





---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message