cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hope Sean <Sean.H...@icl.com>
Subject RE: [Cocoon 2] Build failed
Date Mon, 14 May 2001 09:49:47 GMT
Hi,

I have the same problem. (Cocoon 2.0a5/Solaris 2.7/JDK-1.2.2_008). Removed
previous builds on Cocoon, obtained new version via CVS, and problem
persists.

Has anyone seen and solved this one?

Regards,

Sean Hope

-----Original Message-----
From: Caroline Boonen [mailto:cboonen@morren.com]
Sent: Monday, May 14, 2001 9:52 AM
To: cocoon-users@xml.apache.org
Subject: [Cocoon 2] Build failed


I've try to build cocoon.war and I've this error:

Buildfile: build.xml

init:
------------------- Apache Cocoon 2.0a5 [1999-2001] ----------------

compile:
Compiling 3 source files to /opt/xml-cocoon2/build/cocoon/classes
error: Invalid class file format in
/opt/xml-cocoon2/lib/maybeupload.jar(uk/co/w
eft/maybeupload/MaybeUploadRequestWrapper.class).  The major.minor version
'47.0
' is too recent for this tool to understand.
/opt/xml-cocoon2/build/cocoon/src/org/apache/cocoon/environment/http/Request
Wrap
per.java:21: Class uk.co.weft.maybeupload.MaybeUploadRequestWrapper not
found in
 import.
import uk.co.weft.maybeupload.MaybeUploadRequestWrapper;
       ^
/opt/xml-cocoon2/build/cocoon/src/org/apache/cocoon/environment/http/Request
Wrap
.java:52: Method get(java.lang.String) not found in class
org.apache.cocoon.environment.http.RequestWrapper.
            return ((RequestWrapper) this.req).get(name);
                                                  ^
/opt/xml-cocoon2/build/cocoon/src/org/apache/cocoon/servlet/CocoonServlet.ja
va:339: Incompatible type for =. Explicit cast needed to convert
org.apache.cocoon.environment.http.RequestWrapper to
javax.servlet.http.HttpServletRequest.
                req = new RequestWrapper(request,
                    ^
Note:
/opt/xml-cocoon2/build/cocoon/src/org/apache/cocoon/environment/http/HttpReq
uest.java uses or overrides a deprecated API.  Recompile with "-deprecation"
for details.
5 errors, 1 warning
 
BUILD FAILED
 
/opt/xml-cocoon2/build.xml:312: Compile failed, messages should have been
provided.
 
Total time: 19 seconds              

Somebody already had this problem ? Does have a solution ?

Thanks
-- 

Caroline BOONEN


---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>

---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message