cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Per Bohlin <Per.Boh...@nummerett.se>
Subject Re: XSP: caching?
Date Fri, 04 May 2001 14:06:42 GMT
Tony wrote:
> 
> Donald,
> 
> Sorry to insite, but this is critical for me:
> 
> To make it simple, this is what I added in all my XSP pages, and my
> Cocoon.ini is unchanged since install.
>     public boolean hasChanged (Object context) {return false;}
>     public boolean isCacheable (HttpServletRequest request) {return true;}
> 
> What happen is just one of them appears to be cached (actually the first
> page called after Tomcat is started, no matter which one):
> 
> ...... <!-- This page was served from cache in 10 milliseconds by Cocoon
> 1.8.2 --> .....
> 
> All my XSP pages are asking for cache however this lovely message apprears
> just in this one page.I suspect there is a bug in the 1.8.2 cache managment,
> and I'll be happy if someone confirm this odd beaviour.
> 
> I attached a sample page of my project.
> 
> Tony.
-----------------------------------------------
It also caches the same page requested from one browser, but not the same
page requested from another browser. (as cocoon looks at user-agent, it should
cache these separately). What happens is that the first browser to request
the page gets it from cache on further requests, but the page is then never
cached for the other browser. Restart cocoon, switch order on browsers, same
thing happens. It seems that cocoon only has cache storage for one page?

(cocoon 1.8.2, jakarta-tomcat 3.2, apache 1.3.14, sun jdk 1.2.2, slackware linux
7.1)

/ Per

---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message