cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kieran Buckley" <kbuck...@iwv.com>
Subject nokia phone display problem
Date Wed, 29 Mar 2000 02:03:22 GMT
sorry for taking so long to get back - i didn't have a chance to set up the
hardware until today.
i'm using ericsons gateway - the wap example in cocoon is coming up ok under
the nokia simulator using access via the gateway.
in apaches access log:

127.0.0.1 - - [29/Mar/2000:01:15:50 +0100] "GET
/cocoon/samples/wap/example-portfolio.xml HTTP/1.1" 200 2526
127.0.0.1 - - [29/Mar/2000:01:17:15 +0100] "GET
/cocoon/samples/wap/example-portfolio.xml HTTP/1.1" 200 2526

is what i get with using the nokia 7110.

i set the servlet.log in cocoon.properties to verbose output and i got ..:

2000-03-29 01:15:47 - path="/cocoon" :org.apache.cocoon.Cocoon: init
2000-03-29 01:15:49 - path="/cocoon" :TurbineResources all set!!
2000-03-29 01:15:49 - path="/cocoon" :[org.apache.cocoon.Engine@4826768]
Starting request
2000-03-29 01:15:49 - path="/cocoon"
:[org.apache.cocoon.Engine$Block@3854469] Locking:
Nokia-WAP-Toolkit/2.1:GET:http://localhost:80/cocoon/samples/wap/example-por
tfolio.xml?null
2000-03-29 01:15:49 - path="/cocoon"
:[org.apache.cocoon.Engine$Block@3854469] Total locks for all pages: 1
2000-03-29 01:15:49 - path="/cocoon" :[org.apache.cocoon.Engine@4826768]
Creating page
2000-03-29 01:15:50 - path="/cocoon" :[org.apache.cocoon.Engine@4826768]
Document produced
2000-03-29 01:15:50 - path="/cocoon" :[org.apache.cocoon.Engine@4826768]
Document processed
2000-03-29 01:15:50 - path="/cocoon" :[org.apache.cocoon.Engine@4826768]
Document formatted
2000-03-29 01:15:50 - path="/cocoon" :[org.apache.cocoon.Engine@4826768]
response sent to client
2000-03-29 01:15:50 - path="/cocoon"
:[org.apache.cocoon.Engine$Block@3854469] Releasing lock on:
Nokia-WAP-Toolkit/2.1:GET:http://localhost:80/cocoon/samples/wap/example-por
tfolio.xml?null

for the nokia simulator (which works fine) and:

2000-03-29 01:17:15 - path="/cocoon"
:[org.apache.cocoon.Engine$Block@3854469] Locking: Nokia7110/1.0
(04.88):GET:http://localhost:80/cocoon/samples/wap/example-portfolio.xml?nul
l
2000-03-29 01:17:15 - path="/cocoon"
:[org.apache.cocoon.Engine$Block@3854469] Total locks for all pages: 1
2000-03-29 01:17:15 - path="/cocoon" :[org.apache.cocoon.Engine@4826768]
Creating page
2000-03-29 01:17:15 - path="/cocoon" :[org.apache.cocoon.Engine@4826768]
Document produced
2000-03-29 01:17:15 - path="/cocoon" :[org.apache.cocoon.Engine@4826768]
Document processed
2000-03-29 01:17:15 - path="/cocoon" :[org.apache.cocoon.Engine@4826768]
Document formatted
2000-03-29 01:17:15 - path="/cocoon" :[org.apache.cocoon.Engine@4826768]
response sent to client
2000-03-29 01:17:15 - path="/cocoon"
:[org.apache.cocoon.Engine$Block@3854469] Releasing lock on: Nokia7110/1.0
(04.88):GET:http://localhost:80/cocoon/samples/wap/example-portfolio.xml?nul
l

for the nokia 7110.
All i get from the display on the phone is "connecting to service" until it
eventually times out.
It seems from the servlet log that all is fine at the server side (i don't
think its the user agent string anymore) and its a problem at the phone end:
can someone please help?
thanks in advance
kieran


Hi Kieran,

> Well, I'm not going that far distinguishing different versions
> of the Nokia browser but instead simply Nokia, Phone.com (UP),
> generic WML and generic HTML.
> hi,
>
>
> recently installed cocoon.the wap example comes up ok in the nokia toolkit
> simulator and the html version is ok.using the nokia 7110 phone however
gave
> a connection time out.

How do you access the server?
Is it accessible by the WAP gateway?
Is there a log entry?

> ordinary wml pages came up ok on the phone thus ruling out connection
> problems with the wap gateway. i did mess around with the user agent
> strings, i.e. wap=nokia , wap=Nokia7110 etc.
> (suggestions from checking the mail archives) and still no joy.
> does a separate style-sheet for the 7110 have to be designed?(some code
> examples from the archives seem to refer to two separate style-sheets,one
> for media=wap and media=nokia).

You can use whatever you want as the stylesheet - it just has to work ;-)
And of course you have to define a mapping from the user agent header to
the right stylesheet. Just see the docs for cocoon.properties and the WML
samples.

Again: to find out what arrives at the server look in its log files!

Greetings from Germany,

	Marco
--
Marco Pauck -- marco@pauck.de -- http://www.pauck.de/marco/
For every complex problem, there is a solution that is simple,
neat, and wrong.  -- H. L. Mencken


---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message