cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Berin Loritsch <blorit...@apache.org>
Subject Re: C2 on Solaris 8 install trouble
Date Fri, 16 Mar 2001 04:42:44 GMT
"Lock, Fred" wrote:
> 
> Ok, I give up.
> 
> I've looked through all the email archives, and tried everything mentioned
> there. Still no luck. Please help.
> 
> The trouble is I get the dreaded "The sitemap handler's sitemap is not
> available." message when I try to access C2.
> 
> Here's my setup:
> Solaris 8 (Intel)
> JDK 1.3.0
> Cocoon 2.0a4
> Tomcat 3.2.1
> 
> I've followed the advice in the email archives so that the jars in
> $TOMCAT_HOME/lib are:
> ant.jar, jasper.jar, servlet.jar, webserver.jar, xerces_1_3_0.jar
> 
> I build cocoon.war using:
> $COCOON_HOME/build.sh -Dinclude.webapp.libs=yes webapp
> 
> I then copy $COCOON_HOME/build/cocoon/cocoon.war to $TOMCAT_HOME/webapps.
> 
> I start tomcat with $TOMCAT_HOME/bin/startup.sh and then try to hit
> http://localhost:8080/cocoon
> 
> And that's when I get the message.

Make sure that the tools.jar file is in your CLASSPATH.  You can do this in
one of three ways: include it in an environment variable $CLASSPATH, put the
jar in cocoon/WEB-INF/lib, or add the initial parameter "extra-classpath" to
point to the proper path.

You are getting a ClassNotFoundException in the JavaCompiler class which
means that Cocoon could not find the compiler to create the sitemap and
XSP pages.

---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message