cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Turner <j...@socialchange.net.au>
Subject Re: Cocoon and Tomcat 4.0
Date Wed, 21 Mar 2001 05:04:50 GMT
Hi Erik,

FYI, there's a second beta of Tomcat 4.0 coming out this thursday night (22/3).

On Tue, Mar 20, 2001 at 09:14:33PM -0600, Erik Tennant wrote:
> I am installing Cocoon 1.8.2 on Linux (Redhat 7.0) with Tomcat 4.0b1 and 
> jdk1.3.
> 
> First I want to say thanks to the Cocoon team for creating such thorough 
> installation instructions.. It was extremely helpful (the last time I 
> installed Cocoon was about a year and a half ago, and I remember struggling 
> a lot more with it..).
>
> But.. I am having two problems..
> 
> 1) When I put the w3c.jar in the {$TOMCAT_HOME}/lib directory, I get the 
> following error when I start (or try to stop) Tomcat:

Are you *sure* that's still where jars are meant to go? Tomcat4.0 and 3.3 make
the distinction between container-visible jars and webapp-visible jars.

[snip] 
> 2) If I remove w3c.jar from the lib directory, Tomcat will start.. but then 
> when I try to access the sample Cocoon files, I get the following message:
> 
> java.lang.RuntimeException: Error loading logicsheet at 
> resource://org/apache/cocoon/processor/xsp/library/java/util.xsl due to 
> java.lang.Exception: Resource not found or retrieving error.
> 	at org.apache.cocoon.processor.xsp.XSPProcessor.init(XSPProcessor.java:302)
> 	at org.apache.cocoon.framework.Manager.create(Manager.java:109)
> 	at org.apache.cocoon.framework.Router.init(Router.java:80)
> 	at org.apache.cocoon.framework.Manager.create(Manager.java:109)
> 	at org.apache.cocoon.Engine.<init>(Engine.java:179)
> 	at org.apache.cocoon.Engine.getInstance(Engine.java:232)
> 	at org.apache.cocoon.Cocoon.init(Cocoon.java:157)
> 
> Although cocoon.jar is in the TOMCAT/lib directory, and it does in fact 
> contain the resource util.xsl.  I saw a previous post in the archives 
> suggesting to set the jar files in the system classpath, which I tried, but 
> to no avail.

The fact that the exception includes org.apache.cocoon entries suggests that
the jar is being found.

Btw, are you using the official 1.8.2 distribution, or did you build a jar from
CVS? At one stage, building from CVS would get you a jar with no .xsl files.


--Jeff

> I have tried reordering any xml related jar files in my lib directory (by 
> renaming them), and even removing some, but I was never able to get either 
> error to go away.. Does anyone have any other ideas?  Am I missing 
> something really obvious? Should I go back to Tomcat 3.2? Here are all the 
> files in my lib directory:
> cocoon.jar   fop_0_15_0.jar  jaxp.jar           tools.jar 
> xalan_1_2_D02.jar
> crimson.jar  jasper.jar      namingfactory.jar  turbine-pool.jar 
> xerces_1_2.jar
> 
> Also, on a side note, the installation instructions indicate to add the 
> following to the server.xml file:
> <Context path="/cocoon" docBase="webapps/cocoon" debug="0" 
> reloadable="true" > </Context>
> 
> I found that to get Tomcat 4.0 running, I in fact had to add the following 
> line instead:
> <Context path="/cocoon" docBase="cocoon" debug="0" reloadable="true" > 
> </Context> (leaving out webapps/).. It might be useful to others to add 
> that note to the installation page on the web site.
> 
> Thanks,
> 
> Erik
> 
> 
> ---------------------------------------------------------------------
> Please check that your question has not already been answered in the
> FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>
> 
> To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
> For additional commands, e-mail: <cocoon-users-help@xml.apache.org>

---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message