cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Romang <za...@zataz.com>
Subject Publishing Engine could not be initialized.java.lang.RuntimeException:
Date Sun, 25 Mar 2001 01:51:00 GMT
Hello,

I'm a new user with Cocoon ;)

I have installed on my SuSe 7.1 :

jdk1.3_02
Jakarta-Tomcat-3.2.1
Cocoon-1.8.2

When I ask http://127.0.0.1/cocoon/Cocoon.xml
I have this following error...

Publishing Engine could not be initialized

.java.lang.RuntimeException: Exception when creating " 
org.apache.cocoon.processor.xsp.XSPProcessor" : 
java.lang.NoSuchMethodError: See 
http://xml.apache.org/cocoon/faqs.html#faq-normalize
        at org.apache.cocoon.framework.Manager.create(Manager.java:124)
        at org.apache.cocoon.framework.Router.init(Router.java:80)
        at org.apache.cocoon.framework.Manager.create(Manager.java:109)
        at org.apache.cocoon.Engine.<init>(Engine.java:179)
        at org.apache.cocoon.Engine.getInstance(Engine.java:232)
        at org.apache.cocoon.Cocoon.init(Cocoon.java:157)
        at 
org.apache.tomcat.core.ServletWrapper.doInit(ServletWrapper.java:317)
        at org.apache.tomcat.core.Handler.init(Handler.java:215)
        at org.apache.tomcat.core.ServletWrapper.init(ServletWrapper.java:296)
        at org.apache.tomcat.core.Handler.service(Handler.java:254)
        at 
org.apache.tomcat.core.ServletWrapper.service(ServletWrapper.java:372)
        at 
org.apache.tomcat.core.ContextManager.internalService(ContextManager.java:797)
        at 
org.apache.tomcat.core.ContextManager.service(ContextManager.java:743)
        at 
org.apache.tomcat.service.connector.Ajp12ConnectionHandler.processConnection(Ajp12ConnectionHandler.java:166)
        at 
org.apache.tomcat.service.TcpWorkerThread.runIt(PoolTcpEndpoint.java:416)
        at 
org.apache.tomcat.util.ThreadPool$ControlRunnable.run(ThreadPool.java:498)
        at java.lang.Thread.run(Thread.java:484)

I was in the Cocoon FAQ, and I have seen this error,
but is not an migration from an older version.

This is probably due to incompatibilities between the cocoon.properties 
configuration files in the old version and the new one. Since Cocoon is a 
very modular framework and its architecture is not yet stable, we always 
suggest that you replace your old configuration file with the new one shipped 
with the new release. 

We are working to make sure that this won't be required any more in the 
Cocoon2 generation. For now, we apologize for the inconvenience

I don't think that this message is not for me,
Could somebody help me ?
I'm very enjoy to discover cocoon.

Eric Romang
Zataz.com
zataz@zataz.com

---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message