cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Peter C. Verhage" <pete...@zeelandnet.nl>
Subject &euro; (&#128;) :(
Date Tue, 13 Mar 2001 22:27:38 GMT
I've specified the euro entity in a DTD which I use within my XML page and
within my stylesheet. I also have some other special characters defined in
this DTD like &copy; etc.

They all seem to work fine, when I use &copy; within my stylesheet or
document I will see this entity back within the generated HTML page. But
when I use &euro; I just get a little square (in IE and in NS!) something
like this: [].

I don't think I've made any mistakes, because I use this DTD for a while
know, also with old versions of Cocoon, it all worked fine back then. If I
change <!ENTITY euro "&#128;"> to <!ENTITY euro "&#160;"> I get good output
(the cent sign), so it has something to do with the &#128; symbol. I've
tried changing the encoding of the XML document (US-ASCII, UTF-8,
iso-8859-1), they all don't help a thing.

I also tried to change the browser font, this also does no good. When I look
at the source of the generated page, I will also see the square, if I change
the square to &euro; myself, save the page locally and look at it locally it
will show the euro sign, so it's not a browser/font or whatever problem.

Does anyone know a solution for this problem?!

Regards,

Peter


---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message