cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marco Spinetti" <m.spine...@pisa.iol.it>
Subject INSTALL PROBLEM COCOON2
Date Tue, 27 Mar 2001 09:49:40 GMT
Hi all,
I have tried to install Cocoon 2 with Jakarta-Tomcat 2.3.1 but I have had some problems. 
The operations I have done are the following: 
1)I have installed Tomcat. 
2)I have created Cocoon.war typing " ./build.sh  -Dinclude.webapp.libs=yes webapp  "
3)I have copied Cocoon.war under TOMCAT_HOME/webapps. 
4)I have started Jakarta.

I have obtained a error.

I have tried to rebuild Cocoon replacing in COCOON_HOME/lib Servlet2_2.jar with Jakarta-Tomcat
Servlet.jar but I obtain the following mistake: 
 
Error: 500
Location: /cocoon
Internal Servlet Error:

java.lang.NullPointerException
	at org.apache.cocoon.servlet.CocoonServlet.createCocoon(CocoonServlet.java:506)
	at org.apache.cocoon.servlet.CocoonServlet.init(CocoonServlet.java:125)
	at org.apache.tomcat.core.ServletWrapper.doInit(ServletWrapper.java:317)
	at org.apache.tomcat.core.Handler.init(Handler.java:215)
	at org.apache.tomcat.core.ServletWrapper.init(ServletWrapper.java:296)
	at org.apache.tomcat.core.Handler.service(Handler.java:254)
	at org.apache.tomcat.core.ServletWrapper.service(ServletWrapper.java:372)
	at org.apache.tomcat.core.ContextManager.internalService(ContextManager.java:797)
	at org.apache.tomcat.core.ContextManager.service(ContextManager.java:743)
	at org.apache.tomcat.service.http.HttpConnectionHandler.processConnection(HttpConnectionHandler.java:210)
	at org.apache.tomcat.service.TcpWorkerThread.runIt(PoolTcpEndpoint.java:416)
	at org.apache.tomcat.util.ThreadPool$ControlRunnable.run(ThreadPool.java:498)
	at java.lang.Thread.run(Thread.java:475)

What I have to do?
What 's my error?

Marco Spinetti
m.spinetti@pisa.iol.it



Mime
View raw message