cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Donald Ball <ba...@webslingerZ.com>
Subject Re: I'm trying to install 1.8.1 using Ant
Date Mon, 12 Feb 2001 21:05:23 GMT
On Mon, 12 Feb 2001, Mark Damm wrote:

> Hi, I'm trying to install 1.8.1 using Ant.  When I run build.bat, I
> get 13 errors like:
>
> compile:
>    [javac] Compiling 2 source files to C:\cocoon-1.8.1\build\classes
>    [javac] C:\cocoon-1.8.1\build\src\org\apache\cocoon\processor\xinclude\XIncludeProcessor.java:253:
Method getLocalName() not found in interface org.w3c.dom.Element.
>    [javac] String name = element.getLocalName(); I have another
> version of Ant installed as well as possible *.jar in my classpaths
> but I don't know what to do at this point.  Help!

1. why are you rebuilding 1.8.1 instead of 1.8.2?

2. you have a jar file with the DOM1 api classes before whatever jar file
contains the DOM2 api classes in your classpath. fix that and you will
have no more build problems. if you're using the build scripts, you can
probably just nuke your classpath before building.

- donald


Mime
View raw message