cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Urs Grendelmeier" <urs.grendelme...@svema.ch>
Subject RE: help needed
Date Fri, 09 Feb 2001 22:03:10 GMT
I tried nearly everything - nothing helped! 1.8 works, 1.8.1/1.8.2 do not -
there must be a secret. I don't know the reason, why it works on some
systems and some other have no chance to install it successfully.

I work with 1.8 and wait for Cocoon 2...

Grendi

> -----Original Message-----
> From: alessandro.rolando#popmail.inwind.it@package.it
> [mailto:alessandro.rolando#popmail.inwind.it@package.it]
> Sent: Friday, February 09, 2001 10:51 AM
> To: cocoon-users@xml.apache.org
> Subject: help needed
>
>
> Hello, I'm a new user of cocoon.
> I'm working with Windows2000, Apache, Tomcat 3.2 and Cocoon 1.8.2.
> I have followed the instruction about installing but I have customized
> everything to serve my c:/public_html/ dir.
> Calling URL localhost:8080/cocoon/Cocoon.xml I get the following error:
>
> java.lang.RuntimeException: Exception when creating "
> org.apache.cocoon.processor.xsp.XSPProcessor" :
> java.lang.NoSuchMethodError: See
> http://xml.apache.org/cocoon/faqs.html#faq-normalize
> 	at org.apache.cocoon.framework.Manager.create(Manager.java:124)
> 	at org.apache.cocoon.framework.Router.init(Router.java:80)
> 	at org.apache.cocoon.framework.Manager.create(Manager.java:109)
> 	at org.apache.cocoon.Engine.<init>(Engine.java:179)
> 	at org.apache.cocoon.Engine.getInstance(Engine.java:232)
> 	at org.apache.cocoon.Cocoon.init(Cocoon.java:157)
> 	at
> org.apache.tomcat.core.ServletWrapper.doInit(ServletWrapper.java:317)
> 	at org.apache.tomcat.core.Handler.init(Handler.java:215)
> 	at
> org.apache.tomcat.core.ServletWrapper.init(ServletWrapper.java:296)
> 	at org.apache.tomcat.core.Handler.service(Handler.java:254)
> 	at
> org.apache.tomcat.core.ServletWrapper.service(ServletWrapper.java:372)
> 	at
> org.apache.tomcat.core.ContextManager.internalService(ContextManag
> er.java:79
> 7)
> 	at
> org.apache.tomcat.core.ContextManager.service(ContextManager.java:743)
> 	at
> org.apache.tomcat.service.http.HttpConnectionHandler.processConnec
> tion(HttpC
> onnectionHandler.java:210)
> 	at
> org.apache.tomcat.service.TcpWorkerThread.runIt(PoolTcpEndpoint.java:416)
> 	at
> org.apache.tomcat.util.ThreadPool$ControlRunnable.run(ThreadPool.java:498)
> 	at java.lang.Thread.run(Thread.java:484)
>
> I tried to change the classpath in tomcat wrapper.properties
> putting all the
> cocoon library before tomcat .jar, putting xerces_1_2.jar first of all,
> renaming xml.jar in zzz.jar, but I always catch the exception.
>
> Thanks in advance
> 				Alessandro Rolando
>
>
> ---------------------------------------------------------------------
> Please check that your question has not already been answered in the
> FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>
>
> To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
> For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message