cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matthew Cordes <mcord...@maine.edu>
Subject Re: Servlet API
Date Mon, 05 Feb 2001 17:39:39 GMT
Hello...

On Mon, Feb 05, 2001 at 08:46:54AM -0800, Clover, James C. -ND wrote:
> 
> 
> >From: Ludovic Maitre [mailto:Ludovic.Maitre@sophia.inria.fr]
> >Packaged with Cocoon 1.8.1 is a jar named servlet_2_2. Is there a
> >difference between these jar and the servlet.jar api provided with
> >Tomcat ? I tell this question because i want to use only one of this jar
> >(for having the less possinle libraries with my install)
> 
> The servlet_2_2.jar contains the Servlet API 2.2 classes.  The servlet.jar
> contains an older Servlet API spec.  I'm not sure, but I believe that both
> are required, as Tomcat is a Servlet 2.2-compliant servlet container.
> 
> James

	I'm pretty sure you're in error here.  The servlet.jar that comes with 
	tomcat does in fact contain the classes for the 2.2 servlet spec, thus 
	the servlet_2_2.jar is unneded AFAIK.  Mine works fine w/o it.  Think 
	of it this way, why would tomcat (a 2.2 complaint servlet engine) contain
	jar files for an older API?

	-matt
	

> 
> ---------------------------------------------------------------------
> Please check that your question has not already been answered in the
> FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>
> 
> To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
> For additional commands, e-mail: <cocoon-users-help@xml.apache.org>
> 

Mime
View raw message