cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kowshik.Pod...@ubsw.com
Subject FW: Still experiencing problems setting up Cocoon with Weblogic 6.0
Date Mon, 29 Jan 2001 19:34:27 GMT
After a bit of further investigation, I've realised what's causing the 
problem - Cocoon's lack of use of getResource to locate and read files 
does not work well with Weblogic 6.0 which reads everything out of a 
WAR file, regardless of whether or not a webapp is deployed that way.

I starting writing code which will work this way, and it's starting to 
look better, but I was wondering whether this is already being looked 
at and changed since getResource is the way things should be done 
anyway, and it's not just one place that needs to be changed.

Kosh

> -----Original Message-----
> From: Podder, Kowshik 
> Sent: 29 January 2001 17:15
> To: 'cocoon-users@xml.apache.org'
> Subject: Still experiencing problems setting up Cocoon with 
> Weblogic 6.0
> 
> 
> Hi,
> 
> I am still unable to get Cocoon working with Weblogic 6.0. I 
> can bring up Cocoon.xml fine, but requesting a file such as 
> index.xml in the samples directory results in the following error:
> 
> Error found handling the request.
> java.lang.RuntimeException: Cannot access non-file/war resources
> 	at org.apache.cocoon.Utils.getBasename(Utils.java:277)
> 	at 
> org.apache.cocoon.producer.ProducerFromFile.getDocument(Produc
> erFromFile.java:76)
> 	at org.apache.cocoon.Engine.handle(Engine.java:359)
> 	at org.apache.cocoon.Cocoon.service(Cocoon.java:183)
> 	at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
> 	at 
> weblogic.servlet.internal.ServletStubImpl.invokeServlet(Servle
> tStubImpl.java:208)
> 	at 
> weblogic.servlet.internal.WebAppServletContext.invokeServlet(W
ebAppServletContext.java:1127)
> 	at 
> weblogic.servlet.internal.ServletRequestImpl.execute(ServletRe
> questImpl.java:1529)
> 	at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:137)
> 	at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:120)
> 
> Cocoon is running fine under Tomcat 3.2.1 on the same 
> platform, which is: Solaris 2.6, Sun JDK 1.3, and I've also 
> had it working fine under Weblogic 5.1.
> 
> I have followed the Weblogic 6.0 instructions on the 
> installation page, but I still get the same error - was this 
> installation performed on another platform? Can someone 
> please help me, since I really need to get Cocoon working on 
> Weblogic 6.0.
> 
> Cheers,
> 
> Kosh
> 


Visit our website at http://www.ubswarburg.com

This message contains confidential information and is intended only 
for the individual named.  If you are not the named addressee you 
should not disseminate, distribute or copy this e-mail.  Please 
notify the sender immediately by e-mail if you have received this 
e-mail by mistake and delete this e-mail from your system.

E-mail transmission cannot be guaranteed to be secure or error-free 
as information could be intercepted, corrupted, lost, destroyed, 
arrive late or incomplete, or contain viruses.  The sender therefore 
does not accept liability for any errors or omissions in the contents 
of this message which arise as a result of e-mail transmission.  If 
verification is required please request a hard-copy version.  This 
message is provided for informational purposes and should not be 
construed as a solicitation or offer to buy or sell any securities or 
related financial instruments.


Mime
View raw message