cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Clover, James C. -ND" <James.C.Clover....@disney.com>
Subject Workaround for "sitemap not available error in C2" was: Cocoon2 - Linux - jdk1.3 - tomcat3.2.1
Date Thu, 25 Jan 2001 18:13:43 GMT

>From: Pier Paolo Bortone [mailto:pierpaolo.bortone@netengineering.it]
>I have just make all installations and I'm sure that tomcat runs well. Now
I
>have downloaded and installed cocoon2 following the instruction on the site
>and reading the README in xml-cocoon.
>BUT, when I call
>http://<localhost>/cocoon
>this is the response
>org.apache.cocoon.ProcessingException: The sitemap handler's sitemap is not
>available.

I just saw this last night too.  The problem's been around since about late
December, from what I can tell from the mailing lists.  I'm not sure what
the exact problem is, but it doesn't occur under the latest version of
Tomcat 4.  So to get it to run properly:

1. Download the latest tarball of Tomcat 4 (aka Catalina).
2. Install it -- Tomcat 4 worked for me without any problems.
3. Put your C2 web archive in the Tomcat 4 webapps.
4. Run Tomcat 4 and go to localhost/cocoon.  You will still get an error,
but this lets Tomcat unarchive the .war properly.
5. Change the Cocoon2 web.xml to point to Tomcat 4's classpath.  There is a
section of the web.xml file that looks like this:
  <init-param>
   <param-name>classpath-attribute</param-name>

   <!-- Remove the ones you don't need. -->
   <param-value>
     <!-- This is for Tomcat 3.x -->
     org.apache.tomcat.jsp_classpath

     <!-- This is for Tomcat 4.x -->
     org.apache.catalina.jsp_classpath

     <!-- This is for Coucho Resin -->
     caucho.class.path

     <!-- This is for IBM WebSphere -->
     com.ibm.websphere.servlet.application.classpath
   </param-value>
  </init-param>

Uncomment out all the choices _except_ the Tomcat 4 choice.
6. Restart Tomcat and all should work fine.

James

Mime
View raw message