cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Typrowicz, Jim" <jim.typrow...@gwl.com>
Subject RE: cocoon 1.8 installation with Weblogic 5.1
Date Thu, 18 Jan 2001 18:38:02 GMT
To set up WL5.1 with Cocoon 1.8 I basically followed the Cocoon WL5.1
instructions on the Cocoon Web site.

I've added my specifics below next to each instruction in case you are new
to WL and Cocoon.  Since you mentioned the "cmd" batch files I assume you
are running on NT:


Cocoon directions say:  
Add the xerces, xalan, fop, servlet, and cocoon JAR files (from the
distribution) to your CLASSPATH. (See below). If you're using Java 2, you
should also add the tools.jar file from the JDK distribution to your
CLASSPATH.

What this means for you:
I copied the fop_0_13_0.jar, servlet_2_2.jar, turbine-pool.jar,
xalan_1_2_D02.jar, and xerces_1_2.jar files from the cocoon-1.8\lib
directory to the weblogic\lib directory.  This is not necessary but I chose
to do it.  Also, I dropped the version part of the jar files.  Thus I have
fop.jar, servlet.jar, turbine-pool.jar, xalan.jar and
xerces.jar in my weblogic/lib directory.

I copied the cocoon.jar file from cocoon-1.8\bin to weblogic\lib.

Next, add these to your classpath environment variable.  You can do this
through wlconfig in the weblogic\bin directory, or through regedt32
(Software -> BEA Systems -> Weblogic -> 5.10 -> classpath), or the
startweblogic.cmd file.  I added a simple start file below.
   
Cocoon directions say: 
Create a new subdirectory tree of your WLS run time directory
"cocoonwar/WEB-INF" and copy the default web.xml file (from the src
directory of the distribution) there.

What this means for you:
Just what it says, I created a cocoonwar directory under the weblogic
directory, and then a WEB-INF directory under the cocoonwar directory:
	weblogic->cocoonwar->WEB-INF

Next I copied the web.xml file from cocoon-1.8/src/web-inf directory.  I
changed one line in the web.xml file:
<param-value>[path-to-cocoon]/conf/cocoon.properties</param-value>
TO
<param-value>WEB-INF/cocoon.properties</param-value>

Cocoon directions say:
Copy the cocoon.properties from the conf directory of the distribution to
cocoonwar/WEB-INF and updated the web.xml file to refer to it.

What this means for you:
This is exactly what I did.  Copied the cocoon.properties file from
cocoon-1.8/conf to the weblogic/cocoonwar/WEB-INF directory.  I didn't make
any changes to the cocoon.properties file and I already updated the web.xml
file.

Cocoon directions say:
Copy the samples directory from the distribution to cocoonwar

What this means for you:
Just what it says, copy the cocoon-1.8/samples directory to
weblogic/cocoonwar.  Thus you have: weblogic/cocoonwar/samples.

Cocoon directions say:
Map the web application into the WLS URI name space by adding the following
line to your weblogic.properties file:
weblogic.httpd.webApp.cocoon=cocoonwar

What this means for you:
Just what it says, put the line "weblogic.httpd.webApp.cocoon=cocoonwar"
somewhere in your weblogic.properties file. 



WL simple start script (3 lines):

Assumes you have JDK1.2.2 on your D drive, and this start script is in the
Weblogic directory.  Note, this starts WL statically, which means you cannot
use the hot deploy capability.  I did this because I needed to access WL
classes within my Cocoon Java Producer. I also use Oracle 7.3.4 so that is
what the java.library.path is for.


set JAVA_HOME=D:\jdk1.2.2

set
JAVA_CLASSPATH=.\lib\weblogic510sp6boot.jar;.\lib\weblogic510sp6.jar;.\licen
se;.\classes\boot;.\classes;.\lib\xerces.jar;.\lib\xalan.jar;.\lib\fop.jar;.
\lib\servlet.jar;.\lib\cocoon.jar;%JAVA_HOME%\lib\tools.jar;.\lib\weblogicau
x.jar;

%JAVA_HOME%\bin\java -ms64m -mx64m -classpath %JAVA_CLASSPATH%
-Dweblogic.home=. 
-Dweblogic.system.disableWeblogicClassPath=true -Djava.security.manager
-Djava.security.policy==./weblogic.policy 
-Djava.library.path=./bin/oci734_7 weblogic.Server


Hope this gets you going.



-----Original Message-----
From: Dongqi Guo [mailto:dguo@mobilocity.net]
Sent: Wednesday, January 17, 2001 6:49 PM
To: cocoon-users@xml.apache.org
Subject: cocoon 1.8 installation with Weblogic 5.1


Hi Jamie,

I am installing cocoon 1.8 with Weblogic 5.1 and have the same problem as
you stated in the emails on 1 Nov 2000 and 2 Nov 2000.
I studied the 6 email about this issue and I followed your email on Thu, 2
Nov 2000 11:02:12 -0700:
1. make a SetEnv.cmd
2. make a SetConfig.cmd
3. following the cocoon 1.8 installation with WebLogic 5.1

then I run SetEnv.cmd, then SetConfig.cmd. I check the output of wlconfig,
it's almost the same as yours except that I don't have any service pack jar
file in the any path, and I run bin\wlserver.exe, it give me the error:

[HttpServer] : Directory cocoonwar\ does not contain WEB-INF/weblogic.xml.
If this Web application relies on the WebLogic specific XML descriptor, this
may result in misconfigured application.

I went to: http://localhost:7001/cocoon/index.xml it show up properly, but
when I click any link in it, it does not work.

any help?
thanks

  Dongqi Guo, Engineer

  M o b i l o c i t y   --------------------------
                          The M-Business Builder

  99 Wall Street, 4th Floor, New York, NY 10005
  http://www.mobilocity.net
  646.383.5369 - office
  212.235.0339 - fax
  917.604.0381 - mobile
____________________________________________________________________________
This email may contain confidential and privileged material for the sole use
of the intended recipient. Any review or distribution by others is strictly
prohibited.  If you are not the intended recipient please contact the sender
and delete all copies.



---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
For additional commands, e-mail: cocoon-users-help@xml.apache.org

Mime
View raw message