cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Berin Loritsch <blorit...@apache.org>
Subject Re: XSP Problem after Upgrade
Date Tue, 30 Jan 2001 17:14:15 GMT
Maximilian Rehm wrote:
> 
> Sorry to bug the list about this one . . .
> 
> After upgrading to Tomcat 3.2.1 and Cocoon 1.8.2 I am having trouble getting
> XSP to work.  I receive the following error message
> 
> java.lang.RuntimeException: Exception when creating "
> org.apache.cocoon.processor.xsp.XSPProcessor" :
> java.lang.NoSuchMethodError: See
> http://xml.apache.org/cocoon/faqs.html#faq-normalize

Did you heed the exception text?

See http://xml.apache.org/cocoon/faqs.html#faq-normalize


>         at org.apache.cocoon.framework.Manager.create(Manager.java:124)
>         at org.apache.cocoon.framework.Router.init(Router.java:80)
>         at org.apache.cocoon.framework.Manager.create(Manager.java:109)
>         at org.apache.cocoon.Engine.<init>(Engine.java:179)
>         at org.apache.cocoon.Engine.getInstance(Engine.java:232)
>         at org.apache.cocoon.Cocoon.init(Cocoon.java:157)
>         at org.apache.tomcat.core.ServletWrapper.doInit(ServletWrapper.java:317)
>         at org.apache.tomcat.core.Handler.init(Handler.java:215)
>         at org.apache.tomcat.core.ServletWrapper.init(ServletWrapper.java:296)
>         at org.apache.tomcat.core.Handler.service(Handler.java:254)
>         at org.apache.tomcat.core.ServletWrapper.service(ServletWrapper.java:372)
>         at
> org.apache.tomcat.core.ContextManager.internalService(ContextManager.java:79
> 7)
>         at org.apache.tomcat.core.ContextManager.service(ContextManager.java:743)
>         at
> org.apache.tomcat.service.http.HttpConnectionHandler.processConnection(HttpC
> onnectionHandler.java:210)
>         at
> org.apache.tomcat.service.TcpWorkerThread.runIt(PoolTcpEndpoint.java:416)
>         at
> org.apache.tomcat.util.ThreadPool$ControlRunnable.run(ThreadPool.java:498)
>         at java.lang.Thread.run(Thread.java:484)
> 
> The problem is that in my classpath Xerces_1_2.jar is ahead of the Dom Level
> 1 parsers I know about.  Here is a copy of the classpath Tomcat uses on
> startup:
> 
> Using CLASSPATH:
> C:\Programme\jakarta-tomcat-3.2.1\classes;
> C:\Programme\jakarta-tomcat-3.2.1\lib\aasax-bugfix.jar;
> C:\Programme\jakarta-tomcat-3.2.1\lib\abxerces_1_2.jar;
> C:\Programme\jakarta-tomcat-3.2.1\lib\bsf.jar;
> C:\Programme\jakarta-tomcat-3.2.1\lib\bsfengines.jar;
> C:\Programme\jakarta-tomcat-3.2.1\lib\cocoon.jar;
> C:\Programme\jakarta-tomcat-3.2.1\lib\fop_0_15_0.jar;
> C:\Programme\jakarta-tomcat-3.2.1\lib\servlet.jar;
> C:\Programme\jakarta-tomcat-3.2.1\lib\servlet_2_2.jar;
> C:\Programme\jakarta-tomcat-3.2.1\lib\stylebook-1.0-b2.jar;
> C:\Programme\jakarta-tomcat-3.2.1\lib\turbine-pool.jar;
> C:\Programme\jakarta-tomcat-3.2.1\lib\w3c.jar;
> C:\Programme\jakarta-tomcat-3.2.1\lib\xalan_1_2_D02.jar;
> C:\Programme\jakarta-tomcat-3.2.1\lib\zjaxp.jar;
> C:\Programme\jakarta-tomcat-3.2.1\lib\zparser.jar;
> C:\Programme\jakarta-tomcat-3.2.1\lib\zwebserver.jar;
> C:\Programme\jakarta-tomcat-3.2.1\lib\zxml.jar;
> C:\Programme\jakarta-tomcat-3.2.1\lib\z_ant_1_1.jar;
> C:\Programme\jakarta-tomcat-3.2.1\lib\z_jasper.jar;
> C:\Programme\jakarta-tomcat-3.2.1\lib\servlet_2_2.jar;
> C:\Programme\jakarta-tomcat-3.2.1\lib\jasper.jar;
> C:\Programme\jdk1.3\lib\tools.jar
> 
> I've also check the lib/ext directory.
> 
> Thanks in advance for your help
> Max
> 
> ---------------------------------------------------------------------
> Please check that your question has not already been answered in the
> FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>
> 
> To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
> For additional commands, e-mail: <cocoon-users-help@xml.apache.org>

Mime
View raw message