cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matthew Cordes <mcord...@maine.edu>
Subject Re: esql Problem: no results
Date Fri, 05 Jan 2001 03:37:12 GMT
Hey Donald,


Attachments:
*	esql-test.xml - simple xsp page
*	_esql_test.java - generated java code
*	results - results from 2 trials, 1 that was supposed to 
	cause esql:results to act (this worked) and 1 to test no-results
	this did nothing.

I think there is an error in esql taglib and no-results is never 
being	called because in the template that matches esql:execute-query
(esql:no-results parent) templates matching esql:results, and 
esql:error-results are explicitly applied but there is not one that would
cause the template that matches esql:no-results to be used.  I believe this
block is simply missing as <xsl:apply-templates/> or 
<xsl:apply-templates select="esql:no-results"/>

In any case I could be wrong, please enlighten me.

-matt


On Thu, Jan 04, 2001 at 08:09:29PM -0500, Donald Ball wrote:
> On Thu, 4 Jan 2001, Matthew Cordes wrote:
> 
> > I too have experienced this with 1.39 from cvs ( if there is a newer version
> > please ignore this message ).  The <esql:no-results> block when a sibling
of
> > <esql:results> and child of <esql:execute-query> never seems to be called.
> 
> the no-results element must appear after the results element if it exists.
> it works fine for me. if you are having trouble, send in a message with
> your xsp page and the generated java source code attached.
> 
> - donald
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
> For additional commands, e-mail: cocoon-users-help@xml.apache.org
> 

Mime
View raw message