cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nadine Carlton" <nadine_carl...@hp.com>
Subject Custom tag library question
Date Mon, 29 Jan 2001 19:28:59 GMT
Hi,

  I don't think I understand how tag library stylesheets and document
interact.  I seem to be coding this similarly to other stylesheets,
but I can't access the input XML. Am I coding something incorrectly?
I can't figure it out.  For example, I have an XML file that
uses util:include-file to include an XML document and then I want
to use a tag library on it:

<util:include-file>
<util:name><xsp:expr>inputfile</xsp:expr></util:name>
</util:include-file>

<evue:applystuff>

The tag library is being used because I get an evuetest element,
but the mydebug element is empty, whether I select . or my
root element /evue or the root element of the input document,
evueinput.  The input document is also there in the output.
Here is part of the xsl file.

<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
xmlns:xsp="http://www.apache.org/1999/XSP/Core"
xmlns:evue="http://www.hp.com/evue/core">

....
<xsl:template match="evue:applystuff">
<xsp:logic>
<evuetest> <nadine>version 7</nadine></evuetest>
</xsp:logic>
<mydebug>
<xsl:value-of select="//evueinput"></xsl:value-of>
</mydebug>
<xsl:apply-templates select="//evueinput"></xsl:apply-templates>
</xsl:template>

....

What am I missing?  I'm running 1.7.3.

Nadine Carlton
HP


Mime
View raw message