cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wieser Daniel <Daniel.Wie...@softlab.de>
Subject RE: WLS 5.1.0 and Cocoon Problems
Date Tue, 19 Dec 2000 14:41:04 GMT
I have installed it by just registering the Cocoon Servlet 
to my weblogic.properties file and including all necessary 
jars to the java-classpath. 

That's all. No 'cocoonwar' subdir nor a 'web-inf\web.xml' 
file is needed.

weblogic.properties excerpt:

	weblogic.httpd.register.*.xml=\
		org.apache.cocoon.Cocoon
	weblogic.httpd.initArgs.*.xml=\
		properties=cocoon.properties



I am able to access it under http://host:port/Cocoon.xml


Daniel



> -----Original Message-----
> From: jtyberg@mail.inautix.com [mailto:jtyberg@mail.inautix.com]
> Sent: Tuesday, December 19, 2000 3:16 PM
> To: cocoon-users@xml.apache.org
> Subject: Re: WLS 5.1.0 and Cocoon Problems
> 
> 
> 
> I experienced the same problem and was able to fix it by 
> adding a couple of
> lines to my weblogic.properties file that were not called for by the
> documentation at http://xml.apache.org/cocoon/install.html.  
> I placed my
> cocoon application in {$WEBLOGIC_HOME}/myserver/cocoon.  
> Here's an excerpt:
> 
>      # ------------- added for Cocoon support 
> ---------------------------
>      weblogic.httpd.webApp.cocoon={$WEBLOGIC_HOME}/myserver/cocoon
>      weblogic.httpd.register.*.xml=org.apache.cocoon.Cocoon
>      
> weblogic.httpd.initArgs.*.xml=properties=WEB-INF/cocoon.properties
> 
> I also pointed my documentRoot to my cocoon application directory:
> 
>      weblogic.httpd.documentRoot={$WEBLOGIC_HOME}/myserver/cocoon
> 
> Of course, I also made sure that my classpaths were entirely 
> correct.  Once
> I added the above, I was able to access Cocoon using
> 
>      http://host:port/Cocoon.xml
> 
> Hope this helps.
> 
> Justin
> 
> 
> 
> 
> Please respond to cocoon-users@xml.apache.org
> 
> To:   "cocoon-users@xml.apache.org" <cocoon-users@xml.apache.org>
> cc:
> 
> Subject:  WLS 5.1.0 and Cocoon Problems
> 
> 
> Hi All
> 
> I am relatively new to the Cocoon and have a severe time consuming
> problem.
> I installed Cocoon 1.8 and WLS 5.1.0 and every .xml request 
> is returned
> totally unprocessed. I do not receive any error message and I 
> am nearly
> 100 % sure that my installation and my CLASSPATH plus 
> WEBLOGIC_CLASSPATH
> 
> are ok.
> I believe that my Cocoon does not get instatiated at all.
> 
> Thanks
> 
> Tom
> 
> Thomas.Gozolits@valtech.de
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
> For additional commands, e-mail: cocoon-users-help@xml.apache.org
> 
> 
> 
> 
> 
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
> For additional commands, e-mail: cocoon-users-help@xml.apache.org
> 

Mime
View raw message