cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marco Spinetti" <m.spine...@pisa.iol.it>
Subject R: SERIOUS PROBLEM WITH ESQL.
Date Thu, 21 Dec 2000 08:54:35 GMT
Hi Drasko,
I have not understand well what you mean with "One Servlet Context". I give
you all the information you want.
I use Cocoon 1.8, last version of the Esql, and Jakarta Tomcat as web server
and servlet engine. In the Cocoon.properties file I have inserted the
following lines:
processor.xsp.pool.database.elenco1.driver=oracle.jdbc.driver.OracleDriver
processor.xsp.pool.database.elenco1.url=jdbc:oracle:thin:@xxxxxxx
processor.xsp.pool.database.elenco1.username=xxxxxx
processor.xsp.pool.database.elenco1.password=xxxxxxxx
processor.xsp.pool.database.elenco1.maxConnections=3
processor.xsp.pool.database.elenco1.expiryTime=3600000

processor.xsp.pool.database.elenco.driver=oracle.jdbc.driver.OracleDriver
processor.xsp.pool.database.elenco.url=jdbc:oracle:thin:@xxxxxxxx
processor.xsp.pool.database.elenco.username=yyyyy
processor.xsp.pool.database.elenco.password=yyyyyyy
processor.xsp.pool.database.elenco.maxConnections=3
processor.xsp.pool.database.elenco.expiryTime=3600000

In the two Xsp files which are called one by one form and the other from
other form I use:
1)in the risosta_elenco.xml
<?xml version="1.0"?>
<?cocoon-process type="xsp"?>
<?cocoon-process type="xslt"?>
<?xml-stylesheet href="/xsl/html/elenco/situazione_elenco_abb_loose.xsl"
type="text/xsl"?>
<?xml-stylesheet href="/xsl/html/elenco/situazione_elenco_abb_strict.xsl"
type="text/xsl" media="explorer"?>
<?xml-stylesheet href="/xsl/html/elenco/situazione_elenco_abb_strict.xsl"
type="text/xsl" media="netscape"?>
<?xml-stylesheet href="/xsl/wml/elenco/situazione_abb.xsl" type="text/xsl"
media="wap"?>
<?xml-stylesheet href="/xsl/wml/elenco/situazione_abb.xsl" type="text/xsl"
media="UP"?>
<xsp:page xmlns:xsp="http://www.apache.org/1999/XSP/Core"
xmlns:esql="http://apache.org/cocoon/SQL/v2">
<xsp:structure>
 <xsp:include>xxxxxxxx</xsp:include>
</xsp:structure>
...............
<esql:connection>
     <esql:pool>elenco1</esql:pool>
     <esql:execute-query>
      <esql:query><xsp:expr>query</xsp:expr></esql:query>
.....................
</esql:connection>
..............
</xsp:page>
2) In the risposta_elenco_num.xml
<?xml version="1.0"?>
<?cocoon-process type="xsp"?>
<?cocoon-process type="xslt"?>
<?xml-stylesheet href="/xsl/html/elenco/situazione_elenco_loose.xsl"
type="text/xsl"?>
<?xml-stylesheet href="/xsl/html/elenco/situazione_elenco_strict.xsl"
type="text/xsl" media="explorer"?>
<?xml-stylesheet href="/xsl/html/elenco/situazione_elenco_strict.xsl"
type="text/xsl" media="netscape"?>
<?xml-stylesheet href="/xsl/wml/elenco/situazione_elenco.xsl"
type="text/xsl" media="wap"?>
<?xml-stylesheet href="/xsl/wml/elenco/situazione_elenco.xsl"
type="text/xsl" media="UP"?>
<xsp:page xmlns:xsp="http://www.apache.org/1999/XSP/Core"
xmlns:esql="http://apache.org/cocoon/SQL/v2">
<xsp:structure>
 <xsp:include>xxxxxxxx</xsp:include>
</xsp:structure>
...............
<esql:connection>
<esql:pool>elenco</esql:pool>
     <esql:execute-query>
      <esql:query><xsp:expr>query</xsp:expr></esql:query>
.............
</esql:connection>
..............
</xsp:page>
Am I doing some mistake? Whether you need other pieces of information please
also ask them me.
I thank you for the help
Marco
m.spinetti@pisa.iol.it


----- Original Message -----
From: Drasko Kokic <drasko_kokic@yahoo.com>
To: <cocoon-users@xml.apache.org>
Sent: Thursday, December 21, 2000 9:30 AM
Subject: Re: SERIOUS PROBLEM WITH ESQL.


> Ciao Marco,
>
> are you using only one servlet context?
>
> I have already experienced the problem you are talking
> about ... send me some more info about the
> configuration you are using and I will try to help.
>
> Drasko
>
>
> --- Marco Spinetti <m.spinetti@pisa.iol.it> wrote:
> > PS:I have already sent this letter but my mail
> > server had some problem, so I don't know if it
> > arrived.
> >
>
****************************************************************************
****************
> >
> > Hi all,
> > a serious mistake happens to me while I use Esql and
> > do not know if depends on me or is a Cocoon
> > limitation. My real application of I list telephone.
> > In a Xml page two forms exist: one to find a person
> > through the number and one to find the person's
> > phone number. The two forms send two different Xsp
> > files that use two different pools, or better the
> > database is the itself one( driver and url are the
> > same) but the User-Name and the password are
> > different , therefore I have created two different
> > connection  pools ( Elenco and Elenco1 ).
> > If I try to use a form everything works well; if
> > then I go back to the Page home and use the second
> > form it does not work but I obtain the following
> > mistake.
> > java.sql.SQLException: ORA-00942: table or view does
> > not exist
> >
> > at
> > oracle.jdbc.ttc7.TTIoer.processError(TTIoer.java)
> > at oracle.jdbc.ttc7.Oall7.receive(Oall7.java)
> > at
> >
> oracle.jdbc.ttc7.TTC7Protocol.doOall7(TTC7Protocol.java)
> > at
> >
> oracle.jdbc.ttc7.TTC7Protocol.parseExecuteDescribe(TTC7Protocol.java)
> > at
> >
> oracle.jdbc.driver.OracleStatement.doExecuteQuery(OracleStatement.java)
> > at
> >
> oracle.jdbc.driver.OracleStatement.doExecute(OracleStatement.java)
> > at
> >
>
oracle.jdbc.driver.OracleStatement.doExecuteWithTimeout(OracleStatement.java
)
> > at
> >
> oracle.jdbc.driver.OracleStatement.execute(OracleStatement.java)
> > at
> >
>
_usr._local._jakarta_tomcat._webapps._cocoon._elenco._risposta_elenco.popula
teDocument(_risposta_elenco.java:787)
> > at
> >
> org.apache.cocoon.processor.xsp.XSPPage.getDocument(XSPPage.java:96)
> > at
> >
>
org.apache.cocoon.processor.xsp.XSPProcessor.process(XSPProcessor.java:494)
> > at org.apache.cocoon.Engine.handle(Engine.java:359)
> > at
> > org.apache.cocoon.Cocoon.service(Cocoon.java:167)
> > at
> >
> javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
> > at
> >
>
org.apache.tomcat.core.ServletWrapper.handleRequest(ServletWrapper.java:503)
> > at
> >
> org.apache.tomcat.core.ContextManager.service(ContextManager.java:559)
> > at
> >
>
org.apache.tomcat.service.http.HttpConnectionHandler.processConnection(HttpC
onnectionHandler.java:160)
> > at
> >
>
org.apache.tomcat.service.TcpConnectionThread.run(SimpleTcpEndpoint.java:338
)
> > at java.lang.Thread.run(Thread.java:475)
> >
> > The mistake I do not obtain it if I use a form and
> > then, after making Cocoon restart, use the second. I
> > obtain the only mistake when I use them, first one
> > and then the other, without making restart of new
> > Cocoon.
> > It is as if it kept the table old. What's the
> > mistake?
> > Thanks for the help
> > Marco
> > m.spinetti@pisa.iol.it
> >
> >
>
>
> __________________________________________________
> Do You Yahoo!?
> Yahoo! Shopping - Thousands of Stores. Millions of Products.
> http://shopping.yahoo.com/
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
> For additional commands, e-mail: cocoon-users-help@xml.apache.org
>
>


Mime
View raw message