cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Duane Gran <rag...@spinweb.net>
Subject XSP compile problem with Tomcat 3.2/Cocoon 1.8
Date Fri, 10 Nov 2000 21:25:50 GMT
I am certain that I'm dealing with a pretty common error, but I searched
the mailing list and I haven't found the source of my problems yet.  I get
the following exception when compiling an XSP which is part of the samples
provided with Cocoon 1.8:

"java.lang.NoSuchMethodError: at
org.apache.cocoon.processor.xsp.language.java.XSPJavaPreprocessor"

This is documented in the FAQ as a symptom of having a DOM level 1 library
included before xerces.  The FAQ refers specifically to xml.jar, but I
don't have this listed anywhere in my classpath.  I'm using Tomcat and
below is a listing of all the files in the $TOMCAT_HOME/lib directory:

ant.jar               jasper.jar            test
ant_1_1.jar           jaxp.jar              turbine-pool.jar
bsf.jar               parser.jar            webserver.jar
bsfengines.jar        servlet.jar           xalan_1_2_D02.jar
cocoon.jar            servlet_2_2.jar       xerces_1_2.jar
fop_0_13_0.jar        stylebook-1.0-b2.jar

I realize some of this is redundant, but I don't know exactly which jar
file would contain the offending DOM level 1 library.  Could someone tell
me?

Duane


Mime
View raw message