cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Saravanan Bellan <sa...@siteROCK.com>
Subject Tag Library Problem
Date Tue, 10 Oct 2000 04:10:49 GMT
I'm unable to get my Tag Library to work.

I tried the logicsheet both as a resource:// and as file:// in
cocoon.properties, but no help.

I'm getting a blank page when I request a xsp page which has a custom tag. 

After I remove the JavaXML references from the page, it works fine.

The XSP page and the logic sheet are given below.

Also, I'm unable to see the Debug messages in the Standard output even after
I set the log.level in cocoon.properties to debug.

Actually I got this working on Win98. But when I tried on Solaris I'm having
this problem.

Cocoon ver: 1.8

XSP Page
--------
<?xml version="1.0"?>
<?cocoon-process type="xsp"?>
<xsp:page
   xmlns:request="http://www.apache.org/1999/XSP/Request"
   xmlns:JavaXML="http://www.siterock.com/2000/XSP/JavaXML"
   xmlns:xsp="http://www.apache.org/1999/XSP/Core"
   language="java"
>
<page>
  <head>
    <title>Customer List Page</title>
  </head>
  <menus/>
  <content>
    <title>Customer List</title>
    <request:get-method/>
    <JavaXML:draftTitle/>
  </content>
</page>
</xsp:page>

LogicSheet
----------
<?xml version="1.0"?>
 
<xsl:stylesheet version="1.0"
  xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
  xmlns:xsp="http://www.apache.org/1999/XSP/Core"
  xmlns:JavaXML="http://www.siterock.com/2000/XSP/JavaXML"
>
  <xsl:template match="xsp:page">
    <xsp:page>
      <xsl:copy>
        <xsp:apply-templates select="@*"/>
      </xsl:copy>
    </xsp:page>
  </xsl:template>
 
  <xsl:template match="JavaXML:draftTitle">
    This is the Draft Title
  </xsl:template>
 
  <xsl:template match="@*|*|text()|processing-instruction()">
    <xsl:copy>
       <xsl:apply-templates
            select="@*|*|text()|processing-instruction()"/>
    </xsl:copy>
  </xsl:template>
 
</xsl:stylesheet>	

Please Help,

Thanks,
-sarva

Mime
View raw message