cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From awc <...@dryden.lakeheadu.ca>
Subject Re: 7: Package org.w3c.dom not found in import.
Date Wed, 11 Oct 2000 23:41:24 GMT
I had the same error. That is because cocoo.jar is not on XSP compilers classpath. I edit the
source and the
classpath. Now I am getting this:

      java.lang.IncompatibleClassChangeError: class org.apache.xerces.dom.DocumentImpl does
not implement
interface org.w3c.dom.Document
              at
_usr._local._jakarta._build._tomcat_4_0._webapps._cocoon._servlets._xsp._page.populateDocument(_page.java:58)
              at org.apache.cocoon.processor.xsp.XSPPage.getDocument(XSPPage.java:96)
              at org.apache.cocoon.processor.xsp.XSPProcessor.process(XSPProcessor.java:502)


which is realted to this piece of code from _page.java

-------------*************************--------------
document.appendChild(
            document.createProcessingInstruction(
              "cocoon-process",
              "type=\"xslt\""
-----------*****************************--------

To add the cocoon class path to tomcat-4.0M2, you have to take a look at XSPJavaProcessor.java.
That is where I am right now. and looking..

Anil

Ray Allis wrote:

> Did I read that cocoon 1.8 and tomcat 4.0-m2 were incompatible?
> I don't see it in the mail archive.  I'm missing what?
>
> Ray Allis
> --
> jakarta-tomcat-4.0-m2.tar.gz
> Cocoon-1.8.tar.gz


Mime
View raw message