cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Frederic Alluin <frederic.all...@webmedia.es>
Subject Re: how to (own tag lib)
Date Wed, 11 Oct 2000 15:14:22 GMT
it's true =) but now I have a:

                java.lang.NoClassDefFoundError: Lang
                        at
_D_._WebApps._columbia._htdocs._international._essai.populateDocument(_essai.java:219)

                        at
org.apache.cocoon.processor.xsp.XSPPage.getDocument(XSPPage.java:96)
                        at
org.apache.cocoon.processor.xsp.XSPProcessor.process(XSPProcessor.java:494)

I tried with a Lang.class without package and it runs perfectly =).
With my class in a package I verified with jar -tvf and I get
columbia/Lang.class ..... Sorry but I know it's another silly mistake ;-(

Regards
Fred

Michael Bierenfeld wrote:

> Frederic Alluin wrote:
> >
> > Indeed it's a mistake but apparently not the only one ....
> >
> > java.lang.Exception: XSP Java Compiler: Compilation failed for
> > _essai.java
> >            21: Package columbia not found in import.
> >
> >                  import  columbia.* ;
> >                          ^
>
> If it is for shure in the classpath of the
> servlet-engine => The following could be the error
> :
>
> Check out the jar-file. The File Lang.class has to
> be "columbia/Lang.class". I do make the error
> quite often ;-). Use : jar -tvf webmedia.jar to
> check this.
>
> Regards
>
> Michael
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
> For additional commands, e-mail: cocoon-users-help@xml.apache.org


Mime
View raw message