cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Schulze, Klaus-Peter" <KSchu...@microstrategy.com>
Subject RE: Error with PDF samples
Date Thu, 12 Oct 2000 09:06:30 GMT
-----Original Message-----
From: Robin Green [mailto:greenrd@hotmail.com]
Sent: Donnerstag, 12. Oktober 2000 00:08
To: cocoon-users@xml.apache.org
Subject: Re: Error with PDF samples


"Schulze, Klaus-Peter" <KSchulze@microstrategy.com> wrote:
>I have installed JDK 1.3, JSDK 2.0, Apache 1.3.12, ApacheJServ 1.1.2 and
>Cocoon 1.8 and the samples are working, only the samples concerning the FO
>PDF-generation doesn´t work, even with my own XML-/XSL-Files where FOP 0.14
>works fine as a standalone application. 

That's probably because Cocoon currently ships with FOP0.13 which has a 
different set of image bugs/features/quirks. See the Cocoon FAQ on "how to 
do images with FOP".

Now you might ask "Well why haven't you upgraded it?" The answer is simple -

only me and Donald and Jeremy are really working on Cocoon 1 at the moment 
(on and off), and I for one (I can't speak for the others) don't know 
whether upgrading the supplied FOP from 0.13 to 0.14 would be an improvement

or would introduce too many problems. Opinions?

It´s running but with FOP 0.13 there are some limitations, there is no
text-align="center" in a block and the generation of footers and headers for
a page (xsl-region-after, ...). We want to distribute PDF´s in the intranet
and we need these options.

Best
Klaus-Peter Schulze

Mime
View raw message