cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robin Green" <gree...@hotmail.com>
Subject Re: Test 1.8 on NT
Date Thu, 21 Sep 2000 21:53:03 GMT
"Gabriel Le Van" <levan@arctis.com> wrote:
>I make a test with Cocoon 1.8.dev (following the instruction of Robin 
>Green)
>on NT4 with Apache 1.3.12 and Jserv 1.1.1.
>
>I had the following error with a page where i use an external file :

I'm sorry, I don't understand your test case. Where are all the files 
located? What is the location of the servlet context root?

>The begining of the xml file is :

which file is this?

>
><?xml version="1.0" encoding='ISO-8859-1' standalone="no"?>
><!-- Auteur : ARCTIS (PP/CL/GLV) -->
><!-- Date creation : 31/05/2000 -->
><!-- Version : 1.00 -->
>
><?cocoon-process type="xsp"?>
><?cocoon-process type="xslt"?>
><?xml-stylesheet href="../xsl/wic_dossiersListe.xsl" type="text/xsl"?>
>
><!DOCTYPE page SYSTEM "./librairies/entity.dtd">
>
><xsp:page
>   language="java"
>   xmlns:xsp="http://www.apache.org/1999/XSP/Core"
>   xmlns:session="http://www.apache.org/1999/XSP/Session"
>   xmlns:request="http://www.apache.org/1999/XSP/Request"
>   xmlns:response="http://www.apache.org/1999/XSP/Response"
>   xmlns:sql="http://www.apache.org/1999/SQL"
>   create-session="true"
> >
>     <xsp:structure>
>      <xsp:include>java.sql.*</xsp:include>
>      <xsp:include>com.arctis.webimport.*</xsp:include>
>     </xsp:structure>
>
>  <page title="Liste des dossiers">
>   <!-- récupération des paramètres de filtrage -->
>   <xsp:attribute name="Dossier_Imprime"><request:get-parameter
>name="Dossier_Imprime"/></xsp:attribute>
>   <xsp:attribute name="Dossier_Accepte"><request:get-parameter
>name="Dossier_Accepte"/></xsp:attribute>
>   <xsp:attribute name="Dossier_Valide"><request:get-parameter
>name="Dossier_Valide"/></xsp:attribute>
>   <xsp:attribute name="Dossier_Saisi"><request:get-parameter
>name="Dossier_Saisi"/></xsp:attribute>
>   <xsp:attribute name="Num_Dossier"><request:get-parameter
>name="Num_Dossier" default=""/></xsp:attribute>
>   <xsp:attribute name="Beneficiaire"><request:get-parameter
>name="Beneficiaire" default=""/></xsp:attribute>
>
>   &demarrage;
>
>   <commandes>
>    <creation label="Nouveau dossier à partir d'un modèle :"
>href="./wic_modeleListe.xml?Langue=FR">
>     <image>./../../images/picto-creation.gif</image>
>    </creation>
>    <creation label="Nouvelle demande d'émission :"
>href="./wic_frameDossier.xml?Langue=FR&amp;Action=creation&amp;Titre=Nouveau
>_dossier">
>     <image>./../../images/picto-creation.gif</image>
>    </creation>
>   </commandes>
>
>   <xsp:logic>
>
>
>&demarrage; (the source of the problem)  is declare in an external DTD :
>

I thought external DTDs should not start with <?xml version="1.0"?> It's 
hard to tell from the XML spec, which seems to leave a lot unstated.

Which file is this?:

><?xml version="1.0" encoding='ISO-8859-1'?>
><!ENTITY demarrage SYSTEM "../logique/librairies/xsp_demarrage.xml">
>
>I'am sorry to put only extract of the files but we have to preserve
>confidentiality for our client.

I just need a little more information to reproduce the problem, see 
questions above.


_________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.

Share information about yourself, create your own public profile at 
http://profiles.msn.com.


Mime
View raw message