cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Olivier Richaud" <rich...@cstb.fr>
Subject Re: Strange error
Date Tue, 14 Sep 1999 13:09:17 GMT
I also encountered a similar error with an XSL document (my stylsheet that
converts XML
to HTML). I tried to locate the error, but I'm stuck.

My error appears as soon as my server encounters a load. About 25% of my
requests
are rejected and I get a 500 error...

I suspect Xalan to be the hot spot and I'm wondering whether XT is good
alternative. Any opinion?



Olivier Richaud
CSTB
office: +33 4 93 95 67 24
mobile: +33 6 87 52 53 17
www: http://cic.cstb.fr
----- Message d'origine -----
De : Ulrich Mayring <ulim@denic.de>
À : <cocoon-users@xml.apache.org>
Envoyé : jeudi 14 septembre 2000 15:11
Objet : Strange error


> Hello,
>
> I get this error in my Apache's error logfile:
>
> XSL Error: Could not parse /some/path/style.xsp document!
> XSL Error: SAX Exception
>
> This is an XSLT stylesheet. The strange thing is that other files using
> this stylesheet work fine, the error occurs only with one specific file.
> In the browser, when I access that file and view apache's access log I
> see:
>
> "HEAD / HTTP/1.0" 200 0
> "HEAD / HTTP/1.0" 200 0
> "GET /some/path/myfile.xml HTTP/1.0"
>
> Then, after a while, this is added:
>
> "HEAD / HTTP/1.0" 200 0
> "GET /some/path/myfile.xml HTTP/1.0"
>
> Then the browser gets a "document contained no data" message. Then,
> after I acknowledge this error message in the browser and stop doing
> anything, the whole thing continues:
>
> "HEAD / HTTP/1.0" 200 0
> "HEAD / HTTP/1.0" 200 0
>
> The jserv.log and mod_jserv.log don't show anything. What is happening
> here?
>
> Ulrich
>
> --
> Ulrich Mayring
> DENIC eG, Systementwicklung
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
> For additional commands, e-mail: cocoon-users-help@xml.apache.org
>
>


Mime
View raw message