cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthew Smith" <msm...@windebt.com>
Subject RE: cannot get ESQL to work... urgent
Date Tue, 19 Sep 2000 19:32:20 GMT
	Thanks for the help, but it's still not working.
	I'm getting a compilation error for the esql.xsl file I beleive.  It looks
like the xsp is just missing a semicolon in in some of the java code, but I
checked the file at that location and the java has the semicolon where the
error specifies it's missing one.  Here's the error code.  I have the latest
version of the xsl file as of today.
	Something that really confuses me about it is that the line the error is
reported on is 107, but as best I can tell the actual line of code is at
line 313.  Here's the error cocoon displays:

java.lang.Exception: XSP Java Compiler: Compilation failed for _esql.java
107: ';' expected.
	        _esql_session.resultset.getString("username")
	                                                     ^
1 error

Thanks,
Matt


-----Original Message-----
From: Donald Ball [mailto:balld@webslingerZ.com]
Sent: Saturday, September 16, 2000 12:41 PM
To: cocoon-users@xml.apache.org
Subject: RE: cannot get ESQL to work... urgent


On Fri, 15 Sep 2000, Matthew Smith wrote:

> 	I'm getting the following error when I attempt to use a modified verion
of
> the esql.xml from the samples.  The modifications are just filling in the
> proper driver and connection data, as well as making the query and
requested
> results a lot simpler.  I don't understand the error it one bit.  One
thing
> I noted however, was that when I tried to stick a bit of esql into another
> page, the "Compilation failed for..." would be applicable to
> _nameofxmldocumentrequested.java.
> 	I made all the changes to the properties file, I beleive.  Is
> adding the esql.xls file to the proper src directory and recompiling
> enough?  Do I need to update with other files from the CVS?

you have failed to put the turbine-pool jar file in your servlet engine's
CLASSPATH.

- donald


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
For additional commands, e-mail: cocoon-users-help@xml.apache.org



Mime
View raw message